inkscape Gcode extension copy problem

More
13 Mar 2011 21:04 #7787 by bvandiepenbos
when I try to copy the files to the usr/share/inkscape/extensions ubuntu says I do not have permissions to copy the files.
I am set as Administrator user
root user owns extensions folder, so I think that is the problem.

I did manage to log in as root in a terminal window, but still can not copy files in gui file browser.

copying files from command line is a bit to hairy for me.


help

~*Brian VanDiepenbos

Please Log in or Create an account to join the conversation.

More
13 Mar 2011 21:55 #7790 by andypugh
I think you probably have to use the command line.

The copy command is cp. To use it with root privileges use sudo, ie sudo cp.

Assuming that the file to be copied is called brians.file and is on your desktop type the following (<TAB> means press the tab key for auto-completion)

sudo cp ~/De<TAB>brian<TAB> <SPACE> /usr/share/ink<TAB>ext<TAB>

Please Log in or Create an account to join the conversation.

More
13 Mar 2011 22:09 #7791 by bvandiepenbos
files are in brian/downloads/inkcut
I want to copy inkcut folder and its contents to..
usr/share/inkscape/extensions

what would I type at cl ?

Please Log in or Create an account to join the conversation.

More
13 Mar 2011 22:32 #7792 by andypugh
bvandiepenbos wrote:

what would I type at cl ?


sudo cp ~/downloads/inkcut/* usr/share/inkscape/extensions/

Please Log in or Create an account to join the conversation.

More
13 Mar 2011 23:24 #7796 by bvandiepenbos
grrrrr
that does not work
this should not be so hard

I get error "No such file or directory"

Please Log in or Create an account to join the conversation.

More
14 Mar 2011 00:30 #7800 by andypugh
Sorry, my fault. You need a / before the usr.

sudo cp ~/downloads/inkcut/* /usr/share/inkscape/extensions/

Please Log in or Create an account to join the conversation.

More
14 Mar 2011 00:55 #7801 by bvandiepenbos
well I am closer but still not right...
getting...
cp: omitting directory ...

thanks for trying, but I give up, I must be stupid.

surely there is a way to enable the right permissions for extensions folder so I can use gui file browser.???

if I type sudo bash I get root access, but don't know cl command to change permissions.

I wish I could just get su root access all the time by default
so then can user gui file browser to manage files and folders.
ya, it's not secure but I don't need it to be.

Please Log in or Create an account to join the conversation.

More
14 Mar 2011 01:53 #7803 by Kirk_Wallace
I'm not sure it will help but, if you want to us,e for instance, the text editor as root, open a terminal window and type:

sudo gedit

gedit will open with root privileges. You can do the same for the directory viewer, nautilus

sudo nautilus --browser

this will open nautilus in browser mode. If you add an ampersand to the end of the command,

sudo nuatilus --browser &

this will open nautilus and also release the terminal for other commands. I do this so I can use the up arrow to recall the previous nautilus command in order to open another nautilus - one to copy from, one to copy to.

If you want to change file or directory owner or permissions, right click on the file in sudo nautilus, then select properties, then permissions. You can also change owner or permissions with the terminal with:

sudo chmod (options) (file names)
or
sudo chown (options) (file names)

Use 'man' to see the documentation on these commands:

man chmod
man chown
man (any command)

Use 'q' to quit the man documentation and return to your terminal prompt. Many of the commands have -r or -R as a recursive option, which will let you change a directory and all of the files and directories below it. It can be very handy but also very dangerous so don't use it unless you are sure what will happen.

This is all basic Linux/Gnome/Ubuntu stuff. Basic but not necessarily easy. It might be helpful to go through some basic Ubuntu tutorials if you are going to be playing with EMC2 because you will most likely be creating, changing downloading and moving files.

There is a way to setup Ubuntu to let you log in as root instead of as a sudo user, but don't know how. I've just gotten used to using sudo.
--
Kirk Wallace
www.wallacecompany.com/machine_shop/
www.wallacecompany.com/E45/index.html
California, USA

Please Log in or Create an account to join the conversation.

More
14 Mar 2011 03:00 #7804 by bvandiepenbos
THANKS!
with you detailed info I got done what I needed.
in term window typed sudo bash
then nautilus --browser
in browser navigated to extensions folder and changed its permissions for all users
now I can copy extensions to it from my normal user gui

thanks again
:)

~*Brian VanDiepenbos

Please Log in or Create an account to join the conversation.

Time to create page: 0.159 seconds
Powered by Kunena Forum