Nur X-Achse lässt sich fahren

More
08 Jan 2015 21:55 #54777 by mhe2405
Guten Tag,

ich habe folgendes Problem mit der Konfiguration der Software : Bei der Einrichtung funktionieren alle Achsen und lassen sich Hin und Her fahren, starte ich jedoch nach der configuration das eigentliche Programm
lässt sich nur die X achse fahren. Die anderen Achsen bewegen sich nicht. An was kann das liegen ("Endstufen Aktivieren" muss Invertiert werden bei Y und Z Achse wurde auch in der Konfiguration angegeben)?

Des weiteren bekomme ich zwei Fehler (Siehe fehler.png)

Zum CNC Computer:

Desktop Board mit Onboard LPT Schnitstelle (Parallel Port 278/IRQ5 Port Mode: ECP DMA: 3)
Pentium 4 (3 GHz)
RAM (1 GB)

Mit freundlichen Grüßen
Moritz Hännes
Attachments:

Please Log in or Create an account to join the conversation.

More
09 Jan 2015 00:09 #54790 by ArcEye

Good day,

I have the following problem with the configuration of the software: When ordering function all axes and can go back and forth, but I start after configuration, the actual program
can only be the X-axis drive. The other axes do not move. In what may lie ("Enabling amplifiers" Inverted must be at Y and Z axis is specified in the configuration)?

Furthermore, I get two errors (See fehler.png)

For CNC computer:

Desktop Board with onboard LPT Schnitstelle (Parallel Port 278 / IRQ 5 Port Mode: ECP DMA: 3)
Pentium 4 (3 GHz)
RAM (1 GB)


Hi

Forget the 2nd error for now.

The parport assignments are somewhat non standard, more normally would be something like

1 Charge Pump or Estop
2 X step
3 X dir
4 Y step
5 Y dir
6 Z step
7 Z dir
8 Enable

Your pin assignments show you have 3 enables, but 2 of them are inverted

Unless there is a very good reason for this, seems that will be why 2 axes do not work.
2 will be OFF when the other one is ON

NB You only need 1 enable and share it physically between the 3 drivers

regards

Please Log in or Create an account to join the conversation.

More
09 Jan 2015 01:28 - 09 Jan 2015 01:29 #54797 by mhe2405
Thank you for the fast answer.

Now all axes work
Last edit: 09 Jan 2015 01:29 by mhe2405.

Please Log in or Create an account to join the conversation.

Moderators: HansU
Time to create page: 0.406 seconds
Powered by Kunena Forum