Axis won't run in 8.04 -graphics problem

22 Feb 2010 13:21 - 22 Feb 2010 14:05 #1982 by greeder88
I can't get Axis to run in 8.04 Heron release.
Using built in video card also tried a new ati card... nothing but trouble getting that to work good.
I get a similar error message when I try to run glxgears.
Can't get copy paste to work in emc2 error window so here is the glxgears message:

X Error of failed request: BadRequest (invalid request code or no such operation)
Major opcode of failed request: 144 (GLX)
Minor opcode of failed request: 19 (X_GLXQueryServerString)
Serial number of failed request: 13
Current serial number in output stream: 13

I have integrated video:
VIA Technologies K8M890(Chrome 9)
Is this capable or do I need a video card?
I bought a Ati HD 4350 but I would rather use the integrated video.
Last edit: 22 Feb 2010 14:05 by greeder88. Reason: more info.

Please Log in or Create an account to join the conversation.

22 Feb 2010 14:38 #1983 by andreas59

I am no expert, but I found this text below on

Many onboard video chips cause bad realtime performance. The ones that use some of the system RAM for video ("shared memory") are the worst. If you have realtime problems with a system using onboard video, the first thing to do is disable it and plug in a video card. The closed-source NVidia driver is known to break realtime, so if you have an NVidia card you should try the "nv" or "vesa" drivers.

By installing the package 'libgl1-mesa-swx11' you can get software OpenGL? rendering even if your video card has buggy direct rendering. For more information, [see this mailing list post].

Also take a look here:


Please Log in or Create an account to join the conversation.

22 Feb 2010 15:45 #1988 by greeder88
libgl1-mesa-swx11 is what I needed!

That solved the problem of Axis however when I use my newly purchased ATI HD 4350 video card I can't get higher than 800x600.
I am working on it but if anyone has a fast fix to get beyond the 800x600 don't be shy B)

Please Log in or Create an account to join the conversation.

22 Feb 2010 16:43 - 25 Feb 2010 12:55 #1993 by greeder88
I got it fixed!
Update: Fixed but not working that good. I don't think you can get new cards to work good.

If you have the same problem here is the solution:

First install the following file with Synaptic Package Manager:


If you get only 800x600 resolution you have to edit your xorg.cnf file:

In Terminal type:
sudo gedit /etc/X11/xorg.conf

Once you are in there you have to substitute the following:

Section "Monitor"
Identifier "Configured Monitor"
Vendorname "Generic LCD Display"
Modelname "LCD Panel 1024x768"
Horizsync 31.5-48.0
Vertrefresh 56.0 - 65.0
modeline "640x480@60" 25.2 640 656 752 800 480 490 492 525 -vsync -hsync
modeline "800x600@56" 36.0 800 824 896 1024 600 601 603 625 +hsync +vsync
modeline "800x600@60" 40.0 800 840 968 1056 600 601 605 628 +hsync +vsync
modeline "1024x768@60" 65.0 1024 1048 1184 1344 768 771 777 806 -vsync -hsync
Gamma 1.0

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Defaultdepth 24
SubSection "Display"
Depth 24
Virtual 1024 768
Modes "1024x768@60" "800x600@60" "800x600@56" "640x480@60"

Make sure you delete out the screen section and monitor section that is in there before you paste in the above.
Should save you hours of work.
Last edit: 25 Feb 2010 12:55 by greeder88. Reason: new info.

Please Log in or Create an account to join the conversation.

Time to create page: 0.177 seconds
Powered by Kunena Forum