no "ok" button when starting emc2 2.3.1

  • philip
  • philip's Avatar Topic Author
  • Visitor
  • Visitor
14 Jun 2009 22:30 - 14 Jun 2009 22:31 #429 by philip
Hi guys,

I have a weird problem trying to run emc2 2.3.1.
The computer was succesfully running emc2 2.2 on ubuntu 8.04.
For some reasons it was important to run 2.3 and it was decided to do a clean fresh install instead of updating.
I know that your not supposed to change a running system, but I was made aware of the problem only after a first attempt already failed.

I installed a fresh version of ubuntu 8.04 and then ran the installation script (which was running smoothly).
No error messages at all.
After rebooting with the realtime kernel and trying to run emc2 the system doesn't let me choose a machine configuration. The "OK" button just doesn't appear in the window. It shows all the sample configurations but I can't activate one. The only button that shows is a very big "Cancel" button.
(The same applies also for the Live-CD on this computer, which is running completely fine on a different computer.)

I am not a linux expert so I would be very grateful if someone could point me in a direction where I can search for a solution.
There is no error message in /var/log/messages and nothing else seems to be weird.
Kind regards


P.S.: Just want to assure you, 8.04 and emc2 2.2 were working absolutely fine and powering a small turning machine.
I don't get what the problem could be, all Ubuntu related stuff is working normally.
Last edit: 14 Jun 2009 22:31 by philip. Reason: putting emc2 instead of emc

Please Log in or Create an account to join the conversation.

20 Jun 2009 17:17 #459 by leito1489
Hello philip.

I'm not a linux expert neither, but i got a similar problem as yours.

My problem is that when i boot with the live cd of (version 8.04), i can use emc and everything in the machine config selection, including the OK button and the add a shortcut check box.

But when i finally install the system in the hard drive, i can not create a shortcut, not only with the machine config selection, even if i try to make a shortcut from the desktop to the .ini file of the machine configuration doesn't work, i get an error about something of restricted access or kind of.

I can not give you the right solution because i couldn't find it even for my problem, but you can try installing another ubuntu 8.04 distribution as i did.

For me xubuntu 8.04 fresh install and patched with emc worked ok, i also tried with ubuntu 8.04 server, but i had the same problem, i think may be your problem is similar to what happened to me in my computers, i think is more a problem of compatibility than a general bug.

I know that my answer is not a solution but, may be you can get something of my experience.

Best regards.

Leonardo Marsaglia.

Please Log in or Create an account to join the conversation.

21 Jun 2009 12:18 #462 by BigJohnT

I'm just guessing that it might be some leftover stuff from the previous install.

If you boot from the LiveCD you have the same issue?


Please Log in or Create an account to join the conversation.

Time to create page: 0.187 seconds
Powered by Kunena Forum