Question: Gmoccapy 3.4.2 and touchscreen

More
21 Feb 2023 19:44 #264979 by 0x2102
Hello, 

I recently set up a test system with Debian 11 and LinuxCNC 2.9. In Gmoccapy 3.4.2 I noticed two things in regards to my touchscreen:

1.) I am no longer able to drag the wireframe in Preview. Move it to the left/right or up/down. Mouse works, but not the touchscreen.

2.) In order to set XYZ to a certain value or 0 I would normally touch the Axis letter (X / Y / Z) and enter the value. This works on and off. 
It works better when I click / touch right next to the actual Axis letter. 

Has anybody else noticed this, too? I have tested Axis, QT Dragon, Probe Basic etc, and there I am able to use my touchscreen to move things in Preview. 

Thanks. 
-Markus

Please Log in or Create an account to join the conversation.

More
22 Feb 2023 06:14 #265012 by newbynobi
Hallo 

Ich the preview stuff works with a normal mouse, than I guess it is a touch screen problem. On mine I needed to configure the behavior of the right mouse button.

The DRO hast two areas to react to clicks! If you click on the axis letter, you should get the input screen to enter axis values. If you click in the number area, the DRO will toggle DRO_Absolut ; DRO relative ; DRO distance to go.

Norbert

Please Log in or Create an account to join the conversation.

More
22 Feb 2023 17:46 #265047 by 0x2102
Hi Norbert, 

thanks for getting back to me. What's odd is that is works fine in Axis or any other GUI, just not in Gmoccapy. When you try to drag in Gmoccapy it moves the wireframe 1mm each time. Is there a difference in Axis vs Gmoccapy when it comes to the Preview screen?



Regards,
-Markus

Please Log in or Create an account to join the conversation.

More
22 Feb 2023 20:27 #265065 by HansU
Can you connect a mouse and try the behavior with that? Like Norbert said, I also can't see a difference in behavior between Axis and Gmoccapy using a mouse.

Please Log in or Create an account to join the conversation.

More
22 Feb 2023 20:32 #265066 by 0x2102
Mouse works with both Axis and Gmoccapy.

This is a test system with LCNC 2.9 / Debian 11 and latest Gmoccapy. When I switch back to Debian 10 / LCNC 2.8 and Gmoccapy 3.1.x - it works fine there as well.

Do you have a touchscreen? Is is working for you?

Please Log in or Create an account to join the conversation.

More
23 Feb 2023 08:06 #265112 by HansU
I have a touchscree, but currently not in my vicinity.
It would be interesting to know if it works with Debian 10 and LCNC 2.9 to exclude that is not a driver issue.

Please Log in or Create an account to join the conversation.

More
23 Feb 2023 21:56 - 23 Feb 2023 21:56 #265156 by 0x2102
The problem is with Gmoccapy 3.4.2. 

I have installed a fresh copy of LinuxCNC ISO with 2.8.4 - did a test and then upgraded to 2.10 (master). 
On 2.8.4 it's working fine, but not on 2.9/2.10 with Gmoccapy 3.4.2

Last edit: 23 Feb 2023 21:56 by 0x2102.

Please Log in or Create an account to join the conversation.

More
24 Feb 2023 19:23 #265267 by HansU
Thanks for your testing. I have actually no idea right now. I created an issue here: github.com/LinuxCNC/linuxcnc/issues/2361
The following user(s) said Thank You: Funny

Please Log in or Create an account to join the conversation.

More
07 Oct 2023 23:22 #282522 by newbynobi
I am trying to solve the problem, unfortunately I am not at home and got no touch scrren here.

Could you try:
- Go to settings page
- select mouse button mode (the 5. entry should be the active one)
- change the settings from the 5.entry to the 3. one
- Try to move the preview around

IMHO that is the entry axis is using

Report back.

Norbert

Please Log in or Create an account to join the conversation.

More
13 Oct 2023 19:15 #282933 by 0x2102
Hi Norbert,

I just tried that but it didn't made a difference. Same problem.

Regards,
Markus

Please Log in or Create an account to join the conversation.

Moderators: newbynobiHansU
Time to create page: 0.176 seconds
Powered by Kunena Forum