Strange Issues

More
12 Sep 2021 08:36 - 12 Sep 2021 08:38 #220281 by Willheg
Strange Issues was created by Willheg
Hi all,

I have had my machine working well for some time now, but am having a weird issue and hoping someone may be able to help me work out what I may have happening or may have done wrong.

Here is some background.
I'm was running 2 pci parellel port cards about year ago, then all of a  sudden it started playing up then stopped working. Worked out after some searching I had killed the pci card(s), so had a spare dual port pci card and put it in for it not to work for a bit/pick it up using lspci -vv command, but then managed to get it to work somehow, carnt remember how but anyway.

So there is the background, now to my really part.
I went to do some tweeking last night, pluged everything in as normal, then fired up linuxcnc (V2.7.xx) and this is where i lost my mind, the machine tried to take off in a strange direction make a heck of a noise, estop did not work so had to pull a power plug to kill it.

Upon further "playing/research" I found everything seems to be ok and all untill I open linuxcnc which is when the machine does it weird stuff.

What I'm woundering is has anyone had this happen before, or able to point me in the direction of anything else to try or loom for to see if i can fix this. I'm also woundering if thea software or hardware issue, as like i said its only once i open linuxcnc this happens, so wound have thought if its the pci card it would either not work or do its weird stuff instatly.

Hope the question make sence and someone is able to help point me in the right dirextion of what to try to fix this, I will jave a new pci card on the way in a few days to see if thats the issue but not wanting to kill it right away if I can help it if it is that that I have killed.

Thanks all.
Last edit: 12 Sep 2021 08:38 by Willheg. Reason: Linuxcnc version added.

Please Log in or Create an account to join the conversation.

More
12 Sep 2021 11:20 #220292 by tommylight
Replied by tommylight on topic Strange Issues
Use a grounded 3 prong plug/cable for the PC.
Lack of grounding will do that.

Please Log in or Create an account to join the conversation.

More
13 Sep 2021 09:17 #220416 by Willheg
Replied by Willheg on topic Strange Issues
Thanks tommylight.

Im sure if im correct that i already have 3 prong grounded cables on my pc but i will check and see at some point, change if i need to and go from there.

Please Log in or Create an account to join the conversation.

More
03 Oct 2021 00:12 #222066 by Willheg
Replied by Willheg on topic Strange Issues
Hello again.

I managed to fix this issue somehow, i checked the grounds on everything and that didn't seam to do much, then changed my db25 cables over and that kinda worked to moved the card between the 2 pci slots for about 2 hours trying things and playing with bios settings and now it seams to be working great.

So I think the pc just got outta synch or something, but I now occasionally have one of my axis flip it direction and go in reverse after a power down, no biggy just need to change the invert sig in the *.hal file, but this is a little annoying, so does anyone know how to stop this happening??

Cheers

Please Log in or Create an account to join the conversation.

More
11 Oct 2021 08:42 #222827 by zfa
Replied by zfa on topic Strange Issues
I think this can be electronic noice, do you know this document?

linuxcnc.org/docs/2.8/html/integrator/wiring.html

Please Log in or Create an account to join the conversation.

Time to create page: 0.087 seconds
Powered by Kunena Forum