problems with G1

More
26 Nov 2020 14:06 - 26 Nov 2020 14:07 #190334 by jlviloria
problems with G1 was created by jlviloria
Hello Guys,

I am working with debian whezzy, linuxcnc 2.7.15, mesanet 6i25-7i77.
it is a lathe. programmed with codes G1, cutting feed F0.2 rev / min.
The cutting feed looks good according to the rpm.
but when she reaches the interception points she makes a radius. I program a chamfer and it makes a radius.
my programs have the g64 p0.01 header




Jorge.
Attachments:
Last edit: 26 Nov 2020 14:07 by jlviloria.

Please Log in or Create an account to join the conversation.

More
26 Nov 2020 14:12 #190335 by Aciera
Replied by Aciera on topic problems with G1
Can you post your Gcode? Does this happen just with this programm or is it a general problem? If it is a general problem please post your hal and ini as well.

Please Log in or Create an account to join the conversation.

More
16 Jan 2021 20:46 #195575 by Mru
Replied by Mru on topic problems with G1
Hello, I have strange behavior of G1 command.
Gcode part:
G0 X1116.138 Y632.463
G0 Z15.000
G1 X1116.138 Y632.463 Z0.000 F18000.000
G1 X909.931 Y604.409 Z0.000 F12600.000
G1 X1117.282 Y623.536 Z0.000 F12600.000
G0 Z15.000
G0 Z15.000
G0 X1142.484 Y393.976
G0 Z15.000
G1 X1142.484 Y393.976 Z0.000 F18000.000
G1 X931.590 Y372.768 Z0.000 F12600.000
G1 X1143.541 Y382.023 Z0.000 F12600.000

I need to cut:

Slot B outcome:
Attachments:

Please Log in or Create an account to join the conversation.

More
16 Jan 2021 23:29 #195591 by PCW
Replied by PCW on topic problems with G1
That may be expected behavior unless you have specified a
path following tolerance with G64 PXX QYY

linuxcnc.org/docs/2.4/html/common_User_Concepts.html

Please Log in or Create an account to join the conversation.

More
18 Jan 2021 07:59 #195756 by Mru
Replied by Mru on topic problems with G1
Thanks, I missed this parameter.

Please Log in or Create an account to join the conversation.

Time to create page: 0.264 seconds
Powered by Kunena Forum