Linuxcnc 2.9 jogging velocity fluctuations.

More
25 Apr 2020 21:15 - 27 Apr 2020 10:39 #165578 by tommylight
As the title says, the jog velocity fluctuates, while gcode movement is not affected. Build 1610.
Here is a short video.

--
--
Solution found by PCW :
in a terminal type
xset -r
That will get rid of fluctuations.
Thank you PCW
To make that permanent find "startup applications" from the menu, then add and put xset -r in the command field, close and reboot.
-
some more info about this:
In a terminal copy this:
xev | awk -F'[ )]+' '/^KeyPress/ { a[NR+2] } NR in a { printf "%-3s %s\n", $5, $8 }'
then press the arrow keys and pgup/pgdown, notice the numbers shown, now you can add only those numbers to the command so the rest of the keyboard functions as usual:
xset -r key number
example xset -r 113 will disable repeating only for the left arrow key on my keyboard. This has to be done for every key that is used for jogging the machine.
--
--
The same issue was present on the 2.8 RTAI version, and no amount of keyboard changes gets rid of that.
Will do some test on other PC's to check if that is present.
-
Added
This seems to be hardware related, not software. Had the same issue on another PC, but not on many others i have.
Some quick results:
Linux Debian or Mint has no influence, happened on both.
Linuxcnc 2.9 build 1350 on a Dell, no issues.
Linuxcnc 2.9 build 1427 on a Lenovo laptop, no issues.
This older HP core2duo does that with 3 builds, 1610 and two earlier versions.
-
First instinct was to look at the keyboard, as many of you pointed out, but it looks that the keyboard is not causing that as the same keyboards on the other PC's jog happily, and i have tested some 5 or 6 of them with PS/2 or USB connectors, does not change a thing.
This is most probably the "typematic rate' setting that was adjustable in older BIOS, but it is not on the new ones. Same thing happens when holding down any letter key, the speed of printing it on screen fluctuates !!!
Last edit: 27 Apr 2020 10:39 by tommylight. Reason: marked as solved, not Linuxcnc issue
The following user(s) said Thank You: PKM, Clive S

Please Log in or Create an account to join the conversation.

More
26 Apr 2020 12:46 #165655 by bbsr_5a
if you change the cycle time in TASK just 0,01 up or down it becomes a different behavior
Debian iso 2.9

Please Log in or Create an account to join the conversation.

More
26 Apr 2020 12:52 #165656 by tommylight

bbsr_5a wrote: if you change the cycle time in TASK just 0,01 up or down it becomes a different behavior
Debian iso 2.9

I will test that right now.

Please Log in or Create an account to join the conversation.

More
26 Apr 2020 12:55 #165658 by tommylight
Nope, that is not it. It is set at 0.01 by default.

Please Log in or Create an account to join the conversation.

More
26 Apr 2020 14:33 #165666 by Mike_Eitel
In raspian there seems to be something around time synchronization if not by ntp.

Please Log in or Create an account to join the conversation.

More
26 Apr 2020 14:50 #165667 by tommylight

Mike_Eitel wrote: In raspian there seems to be something around time synchronization if not by ntp.

Nope, stopping systemd-timesyncd and starting (after install) of ntp, does not change the behaviour, so the fluctuations remain.

Please Log in or Create an account to join the conversation.

More
26 Apr 2020 15:07 #165670 by tommylight
This is a screenshot of halscope doing a jog in negative direction, it can be clearly seen that there are drops in commanded velocity. This is a servo system with Mesa 6i25, PS/2 and USB keyboard.
That can also be heard from the motors, and it makes stepper system stall at higher speeds.
Attachments:

Please Log in or Create an account to join the conversation.

More
26 Apr 2020 16:22 #165674 by Todd Zuercher
is it possible to check the input of the keyboard command with halscope? I have not messed with Master or 2.8 much, but I have seen such behavior on other versions of Linuxcnc when trying to control it via remote desktop (VNC).
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
26 Apr 2020 17:32 - 26 Apr 2020 17:33 #165676 by PCW
I would guess its a keyboard issue also since the error is from motion

You could also check to see if the drops in velocity violate the acceleration
constraints (by plotting at a lower time per division and checking the slopes)

Another thing to try is to see if pure hal jogging shows the same issue
(maybe just setp-ing the correct halui pins with halcmd)

BTW I cannot duplicate this with keyboard jogging and LinuxCNC 2.9 here
Last edit: 26 Apr 2020 17:33 by PCW.
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
26 Apr 2020 18:25 #165677 by tommylight
This seems to be hardware related, not software. Had the same issue on another PC, but not on many others i have.
Some quick results:
Linux Debian or Mint has no influence, happened on both.
Linuxcnc 2.9 build 1350 on a Dell, no issues.
Linuxcnc 2.9 build 1427 on a Lenovo laptop, no issues.
This older HP core2duo does that with 3 builds, 1610 and two earlier versions.
-
First instinct was to look at the keyboard, as many of you pointed out, but it looks that the keyboard is not causing that as the same keyboards on the other PC's jog happily, and i have tested some 5 or 6 of them with PS/2 or USB connectors, does not change a thing.
This is most probably the "typematic rate' setting that was adjustable in older BIOS, but it is not on the new ones. Same thing happens when holding down any letter key, the speed of printing it on screen fluctuates !!!
-
Thank you all for continued support, it is very much appreciated.
Marking the topic as solved.
regards,
Tom.

Please Log in or Create an account to join the conversation.

Time to create page: 0.139 seconds
Powered by Kunena Forum