- Posts: 64
- Thank you received: 4
Downgrading from 2.9 to 2.8.4 stretch
3 years 7 months ago - 3 years 7 months ago #266235
by evengravy
Downgrading from 2.9 to 2.8.4 stretch was created by evengravy
Hey. I've been running 2.9 for a while, pre0 release on debian stretch. I've been encountering some issue so went to upgrade to master but seems to be buster only now. I probably shouldn't have made the jump so early but anyway. Is it feasible to downgrade to 2.8.4 now that a version is there for mesa 7i96? Or would you suggest a fresh install. I had a wee search but couldn't find anything. I guess noone is as daft as me to run their two machines on an early dev version. (Not complaining, just curious).
Related, are there any key issues with differences in hal and ini between the two? I understand 2.8 has joints etc like 2.9 (im using dual synchronised ballscrews and "squaring" on y)
Related, are there any key issues with differences in hal and ini between the two? I understand 2.8 has joints etc like 2.9 (im using dual synchronised ballscrews and "squaring" on y)
Last edit: 3 years 7 months ago by evengravy.
Please Log in or Create an account to join the conversation.
3 years 7 months ago - 3 years 7 months ago #266277
by andypugh
Replied by andypugh on topic Downgrading from 2.9 to 2.8.4 stretch
There should be no config differences between 2.9 and 2.8.x
You should be able to just force the version to 2.8.4 in the Synaptic package manager. There are 2.8.4 packages for Stretch.
(edit) You might also have to change the repository settings to point at the 2.8 version. This will be the same instructions in that respect to updating 2.7 to 2.8:
linuxcnc.org/docs/stable/html/getting-st..._setting_apt_sources
Just follow steps 1.1 and 1.2
You should be able to just force the version to 2.8.4 in the Synaptic package manager. There are 2.8.4 packages for Stretch.
(edit) You might also have to change the repository settings to point at the 2.8 version. This will be the same instructions in that respect to updating 2.7 to 2.8:
linuxcnc.org/docs/stable/html/getting-st..._setting_apt_sources
Just follow steps 1.1 and 1.2
Last edit: 3 years 7 months ago by andypugh.
The following user(s) said Thank You: evengravy
Please Log in or Create an account to join the conversation.
3 years 7 months ago #266279
by zz912
Replied by zz912 on topic Downgrading from 2.9 to 2.8.4 stretch
Another way is uninstall LCNC and use RIP installation.
linuxcnc.org/docs/2.9/html/code/building-linuxcnc.html
It is not easy, but you can install several versions LCNC.
linuxcnc.org/docs/2.9/html/code/building-linuxcnc.html
It is not easy, but you can install several versions LCNC.
The following user(s) said Thank You: evengravy
Please Log in or Create an account to join the conversation.
3 years 7 months ago - 3 years 7 months ago #266288
by evengravy
Replied by evengravy on topic Downgrading from 2.9 to 2.8.4 stretch
Thanks gents. Im trying an install of 2.9 on another drive with 5.10 rt kernel. Will see how it does. Good to know the config didn't change from 2.8 to 2.9. I remember 2.7 to 2.8 was a big change due to joints etc. Im not sure how well my machine will do with debian 11 but, since 2.9 isn't maintained for stretch due to python 2 I guess its good to change. Otherwise its back to 2.8.4 on stretch I guess. Appreciate the info. J
I may try the RIP actually, thanks. Ill see how the latency is on 11 and go from there. Im currently building from git based on gnipsels instructions (for first time) so we'll see how that goes too
I may try the RIP actually, thanks. Ill see how the latency is on 11 and go from there. Im currently building from git based on gnipsels instructions (for first time) so we'll see how that goes too
Last edit: 3 years 7 months ago by evengravy.
Please Log in or Create an account to join the conversation.
3 years 7 months ago #266290
by zz912
Replied by zz912 on topic Downgrading from 2.9 to 2.8.4 stretch
I wanted to ask why are you trying Debian 11? I know there are a lot of people here trying different Linux distributions, but I've always wondered what makes them do it.
The following user(s) said Thank You: evengravy
Please Log in or Create an account to join the conversation.
3 years 7 months ago - 3 years 7 months ago #266292
by evengravy
Replied by evengravy on topic Downgrading from 2.9 to 2.8.4 stretch
I've been having some issues with my 2.9 system with read errors to the 7i96 (in another thread) i actually have two machines with 7i96 both are producing the same issue. I've replaced the NIC with an intel and have the same issue and have a strong feeling it is machine(PC) related/config. Id be more than happy to stay with stretch (i have another machine running an old ubuntu install and im in no rush to update it) but since 2.9 is not available on stretch I have to either go up to 10/11 to install 2.9 or stick with stretch and downgrade to 2.8.4. If that makes sense. Im very much happy with any version of Linux that works reliably. My ubuntu box hasn't been updated since and never skips a beat so it'll be like that till it dies I guess. I need 2.8 plus to support dual y axis and the 7i96 too so choices are a bit more limited. Also v 11 is known to be more stable kernel wise for the NIC as far as I'm aware so that is why is skipped 10. I was trying also to stay with 2.9 so I don't have to worry much about config changes (if any) since it has two machine configs on there.
Last edit: 3 years 7 months ago by evengravy.
Please Log in or Create an account to join the conversation.
Time to create page: 0.166 seconds