NGCGUI error with BackToolLathe

More
24 Jun 2013 16:17 #35973 by bjames28
Dear All,

Friend of mine uses BackToolLathe .axisrc from from Wiki .
When he hits the Finalize button in NGCGUI, there is an error message as follows:
Exception in Tkinter callback
Traceback (most recent call last):
File "/usr/lib/python2.6/lib-tk/Tkinter.py", line 1413, in __call__
return self.func(*args)
File "/usr/bin/axis", line 1892, in remote
commands.open_file_name(arg)
File "/usr/bin/axis", line 1906, in open_file_name
commands.set_view_y()
File "/home/aron/.axisrc", line 13, in set_view_y
if o.g:
AttributeError: MyOpengl instance has no attribute 'g'


Do you have any suggestion how to fix it?

Best regards:
James

Please Log in or Create an account to join the conversation.

More
24 Jun 2013 18:08 #35975 by ArcEye
Hi

This error comes up when you start Axis, it is nothing to do with ngcgui.
Your friend probably does not start it from a terminal so never sees the error unless using ngcgui.

I can confirm the error warning in a sim, but so far as I can tell it does not affect the functionality, the back lathe plot works as it should
A lot of python errors seem to be like that.

I tried a few hacks but can't get rid of it, I'll leave it for JT to have a look at, I see it has his paw prints on it B)

regards

Please Log in or Create an account to join the conversation.

More
24 Jun 2013 22:14 #35990 by BigJohnT


I tried a few hacks but can't get rid of it, I'll leave it for JT to have a look at, I see it has his paw prints on it B)

regards


I know nothing about Tkinter so it can't have my paw prints on it.

Seems I ran into that with gremlin and if you try and set a view with nothing loaded you get an error.

JT
The following user(s) said Thank You: bjames28

Please Log in or Create an account to join the conversation.

More
24 Jun 2013 22:56 #35994 by ArcEye

I know nothing about Tkinter so it can't have my paw prints on it.


I was going by the name against the edits on the wiki page :whistle:

Please Log in or Create an account to join the conversation.

More
24 Jun 2013 23:24 #35997 by BigJohnT

I know nothing about Tkinter so it can't have my paw prints on it.


I was going by the name against the edits on the wiki page :whistle:


Ah yes, I did the promotional part of it LOL.

JT

Please Log in or Create an account to join the conversation.

More
27 Jun 2013 14:19 #36118 by bjames28
Thanks ArcEye, BigJohnT for the information.

OK, it seem that the Tkinter related message can be ignored.

The strange thing is that the correct G code is sent from NGCGUI sub to Axis, just there is an error message window saying that no error :blink:



The question is if this error message is caused by NGCGUI subroutine or NGCGUI itself?

Regards:
James

Please Log in or Create an account to join the conversation.

More
27 Jun 2013 20:50 - 27 Jun 2013 23:13 #36138 by ArcEye

The question is if this error message is caused by NGCGUI subroutine or NGCGUI itself?


The error message seems related to Gremlin, which is the openGL plot rendering widget present both in Axis and the new ngcgui by the looks of it.

It occurs when Axis opens and tries to implement the backtool revision code from ~/.axisrc and it appears it also occurs when the embedded Gremlin
widget tries to render the completed code from ngcgui.

Dewey might be able to isolate what is causing it, I will draw his attention to the thread in case he has an input.

In the meanwhile it does not seem to affect anything so just carry on

regards
Last edit: 27 Jun 2013 23:13 by ArcEye.

Please Log in or Create an account to join the conversation.

More
27 Jun 2013 21:58 #36139 by BigJohnT
Does the SendFileToAxis failed message mean anything?

JT

Please Log in or Create an account to join the conversation.

More
27 Jun 2013 23:11 #36140 by ArcEye

Does the SendFileToAxis failed message mean anything?


I assume not

bjames28 wrote:

The strange thing is that the correct G code is sent from NGCGUI sub to Axis


I am still using the original ngcgui so i am not even familiar with this version.

I sent Dewey an email, he's the man to answer this

regards
The following user(s) said Thank You: bjames28

Please Log in or Create an account to join the conversation.

More
27 Jun 2013 23:55 #36141 by BigJohnT
I got a reply back from Dewey.

I am out of town so can't do much ---the red text says the send to axis failed so he could ctrl-a to toggle autosend and save the NgC file to try running in axis and/or to post so others can look at the file


JT

Please Log in or Create an account to join the conversation.

Time to create page: 0.294 seconds
Powered by Kunena Forum