Gmoccapy: Tastspitze schon ausgelöst.

More
28 Feb 2020 20:14 #158780 by Uli
Hallo liebe CNC -Gemeinde,

bis her war ich nur stiller Mitleser und habe auch so einige gute Informationen finden können.
Die Maschine, eine kleine selbst gebaute Hobbyfräse, läuft mit LinuxCNC wirklich klasse.
Nun stehe ich aber vor eine für mich unüberwindbare Hürde. Habe schon viele Stunden damit verbracht
die automatische Werkzeugvermessung einzurichten. Aber das scheint die Nadel im Heuhaufen zu sein.
Mit "try and error" komme ich nicht weiter.

Alles nach Anleitung eingerichtet, meine ich jedenfalls. Das erste was merkwürdig ist, die Datei "change.ngc"
ist fehlerhaft? Nach Aufforderung das Werkzeug zu wechseln bekomme ich die Fehlermeldung
"File ended with no percent sign or program end" Habe aus Verzweiflung ein M2 unten dran gehangen, geht das?

Egal welche Parameter ich eingebe. Die Fehlermeldung " Tastspitze schon ausgelöst bei Start durch G38.4 oder G38.5"
Mein Taster ist ein schließer, in der HAL-Show unter "Probe" von Gelb auf Braun erkennbar.
Angeschlossen an PIN 15

Jemand eine Idee?

Gruß aus Duisburg
Ulrich

Please Log in or Create an account to join the conversation.

More
28 Feb 2020 20:24 - 28 Feb 2020 20:24 #158781 by tommylight
Im hal:

net something something parport.0.pin-15-in
aus
net something something parport.0.pin-15-in-not
Last edit: 28 Feb 2020 20:24 by tommylight. Reason: added more info
The following user(s) said Thank You: Tchefter

Please Log in or Create an account to join the conversation.

More
28 Feb 2020 20:37 #158783 by MaHa
change.ngc:
o<change> sub
your code
o<change> endsub
M2


Betreffend G38:
G38.2 / G38.3 fährt auf Taster. Zuerst mit gutem Vorschub, F500 oder so anfahren
G38.4 / G38.5 fährt weg von ausgelöstem Taster. Mit F10 abheben und Ergebnis #5063 auswerten
The following user(s) said Thank You: Tchefter

Please Log in or Create an account to join the conversation.

More
28 Feb 2020 20:45 #158784 by Uli
Hallo tommylight,

danke für die schnelle Antwort. Das war ein guter Tip. Zumindest die Spindel fährt
jetzt runter, aber in Langsamfahrt und wenn der Taster auslöst fährt sie ca. 4mm wieder nach oben bleibt dann stehen mit der üblichen Meldung "Tastspitze schon ausgelöst bei Start durch G38.4 oder G38.5". Vielleicht helfen da meine Zahlen weiter:[TOOLSENSOR]
X = 0.00
Y = 40.00
Z = 90.00
MAXPROBE = -58.00

[CHANGE_POSITION]
X = 0.00
Y = 30.0
Z = 90

Tasterhöhe : 32.1
Werkstück: 6mm hoch (Kunststoffplatte)

Please Log in or Create an account to join the conversation.

More
28 Feb 2020 20:58 #158786 by Uli
Vielen vielen Dank an Euch, läuft einwandfrei.
Es lag also an der Geschwindigkeit und am verdrehten PIN
Ihr seid Spitze, Danke das wars.

Gruß
Uli

Please Log in or Create an account to join the conversation.

Time to create page: 0.066 seconds
Powered by Kunena Forum