Netzwerverbindung 7i76e

More
15 Mar 2021 09:44 #202321 by klamos
Hallo! Ich habe ein Problem mit der Netzwerkverbindung mit der 7i76e: Ich kann die Karte anpingen und sie wird gefunden. Jumper W3 habe ich umgsteckt und die Adr 10.10.10.10 vergeben.
mesaflash habe ich auch installiert. Mit dem Befehl $ sudo mesaflash --device 7i76e --addr 10.10.10.10 --readhmid kommt immer die Fehlermeldung No 7i76e board found.
In der wicd Netzwerkverbindung wird die KArte verbunden.
Nach der Einrichtung der Achsen über pnwizard von Linuxcnc und das Aufrufen von "Mesa7i76e" erscheint im Report folgende Meldung:
hm2_eth: ERROR: Could not retrieve hardware address (MAC) of 10.10.10.10: Resource temporarily unavailable
Wo liegt der Fehler? Leider ist mein Englisch=0 Die Grundlage für die Einrichtung waren die Youtube Videos von "talla83" #19
Danke für eure Hinweise!
Klamos

Please Log in or Create an account to join the conversation.

More
15 Mar 2021 11:19 #202331 by tommylight
Replied by tommylight on topic Netzwerverbindung 7i76e
Was gibt bei
Ip -a
Im terminal?

Please Log in or Create an account to join the conversation.

More
15 Mar 2021 20:43 - 16 Mar 2021 10:48 #202405 by klamos
Replied by klamos on topic Netzwerverbindung 7i76e
hat er gefunden: was muss hier drin stehen?

Das steht bei mir drin:
klaus@klaus-cnc:~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp6s0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
link/ether 6c:62:6d:85:f9:51 brd ff:ff:ff:ff:ff:ff
inet6 fe80::6e62:6dff:fe85:f951/64 scope link
valid_lft forever preferred_lft forever
3: wlp4s7: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc noqueue state DOWN group default qlen 1000
link/ether 82:96:64:e7:8c:ae brd ff:ff:ff:ff:ff:ff
Last edit: 16 Mar 2021 10:48 by klamos.

Please Log in or Create an account to join the conversation.

More
16 Mar 2021 06:54 #202454 by Aciera
Replied by Aciera on topic Netzwerverbindung 7i76e

hat er gefunden: was muss hier drin stehen?


Schwer zu sagen, poste doch mal den output vom terminal dann sieht man vielleicht ob etwas falsch konfiguriert ist.

Please Log in or Create an account to join the conversation.

More
16 Mar 2021 14:14 #202477 by klamos
Replied by klamos on topic Netzwerverbindung 7i76e
-cnc:~$ ip a
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
inet6 ::1/128 scope host
valid_lft forever preferred_lft forever
2: enp6s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
link/ether 6c:62:6d:85:f9:51 brd ff:ff:ff:ff:ff:ff
inet 169.254.9.69/16 brd 169.254.255.255 scope link enp6s0:avahi
valid_lft forever preferred_lft forever
inet6 fe80::6e62:6dff:fe85:f951/64 scope link
valid_lft forever preferred_lft forever
3: wlp4s7: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
link/ether 82:96:64:e7:8c:ae brd ff:ff:ff:ff:ff:ff
inet 10.0.0.28/24 brd 10.0.0.255 scope global dynamic wlp4s7
valid_lft 72882sec preferred_lft 72882sec

Please Log in or Create an account to join the conversation.

More
20 Mar 2021 07:05 #202933 by Mike_Eitel
Replied by Mike_Eitel on topic Netzwerverbindung 7i76e
Es sieht so aus als wenn Du am Ethernet keinen 10.10.10.(alles nur nicht 10) Adresse vereinbart hast. Dafür dein WLAN die 10.0.0.28 hat, die geht, ist aber auch ungewöhnlich. Mike
The following user(s) said Thank You: klamos

Please Log in or Create an account to join the conversation.

More
20 Mar 2021 16:10 #202992 by klamos
Replied by klamos on topic Netzwerverbindung 7i76e
Danke, das habe ich geschafft! Mir einer zusätzlichen LAN Karte war es dann ziemlich bald soweit. Offenbar hat sich das WLAN quergestellt.

Please Log in or Create an account to join the conversation.

More
05 Apr 2021 09:24 - 05 Apr 2021 09:43 #204868 by klamos
Replied by klamos on topic Netzwerverbindung 7i76e
Da muss es noch ein anderes Problem geben. Ich habe debian 9.0 und linuxcnc nohmals neu installiert, weil ich ein Problem mit den Schrittbewegungen hatte. Die Achsen im pncconfig haben alle die richtigen Schrittverhältnisse. Jedoch wenn ich einen Job gefräst habe waren die Achsenwege ca die Hälfte von den richtigen Werten. Ich konnte den Feher nicht finden. Dh. Neuinstallation! Und jetzt kann ich die Karte anpingen aber ich bekomme keine Rückmeldung bzw. folgende Fehlermeldung, wenn ich die Maschine starten will.

Error report created by /usr/lib/tcltk/linuxcnc/show_errors.tcl:

Print file information:
RUN_IN_PLACE=no
LINUXCNC_DIR=
LINUXCNC_BIN_DIR=/usr/bin
LINUXCNC_TCL_DIR=/usr/lib/tcltk/linuxcnc
LINUXCNC_SCRIPT_DIR=
LINUXCNC_RTLIB_DIR=/usr/lib/linuxcnc/modules
LINUXCNC_CONFIG_DIR=
LINUXCNC_LANG_DIR=/usr/lib/tcltk/linuxcnc/msgs
INIVAR=inivar
HALCMD=halcmd
LINUXCNC_EMCSH=/usr/bin/wish8.6
LINUXCNC - 2.8.1
Machine configuration directory is '/home/klaus/linuxcnc/configs/xyza'
Machine configuration file is 'xyza.ini'
INIFILE=/home/klaus/linuxcnc/configs/xyza/xyza.ini
VERSION=1.1
PARAMETER_FILE=linuxcnc.var
TASK=milltask
HALUI=halui
DISPLAY=axis
COORDINATES=XYZA
KINEMATICS=trivkins coordinates=XYZA
Starting LinuxCNC...
Starting LinuxCNC server program: linuxcncsvr
Loading Real Time OS, RTAPI, and HAL_LIB modules
Starting LinuxCNC IO program: io
Starting HAL User Interface program: halui
Found file(REL): ./xyza.hal
Shutting down and cleaning up LinuxCNC...
Running HAL shutdown script
hm2: loading Mesa HostMot2 driver version 0.15
hm2_eth: loading Mesa AnyIO HostMot2 ethernet driver version 0.2
hm2_eth: ERROR: Could not retrieve hardware address (MAC) of 10.10.10.10: Connection refused
hm2: unloading
Removing HAL_LIB, RTAPI, and Real Time OS modules
Removing NML shared memory segments

Debug file information:
Note: Using POSIX realtime
hm2_eth: rtapi_app_main: Connection refused (-111)
./xyza.hal:9: waitpid failed /usr/bin/rtapi_app hm2_eth
./xyza.hal:9: /usr/bin/rtapi_app exited without becoming ready
./xyza.hal:9: insmod for hm2_eth failed, returned -1
2033
Stopping realtime threads
Unloading hal components
Note: Using POSIX realtime



-
Last edit: 05 Apr 2021 09:43 by klamos.

Please Log in or Create an account to join the conversation.

More
05 Apr 2021 11:43 #204881 by Aciera
Replied by Aciera on topic Netzwerverbindung 7i76e
So als Tipp: Du brauchst nicht gleich jedesmal neuinstallieren wenn etwas mit der Konfiguration nicht hinhaut. Das Problem mit der Achsskalierung hätten wir vermutlich recht einfach in der INI lösen können.

Please Log in or Create an account to join the conversation.

More
05 Apr 2021 17:50 - 05 Apr 2021 17:52 #204928 by klamos
Replied by klamos on topic Netzwerverbindung 7i76e
Danke! Ich habe nach vielen Möglichkeiten, die ich versucht habe keine andere Lösung mehr gesehen. Hast du einen Vorschlag, wie ich die Karte aktivieren kann? Mesaflash habe ich installiert. Wenn ich nach erfolgreichen anpingen den Befehl sudo mesaflash --device 7i76e --addr 10.10.10.10 --readhmid eingebe erscheint die Meldung: No 7I76E board found
Beim Starten der Maschine erscheint dann der ober bereits angeführte Fehlerkommentar!
Last edit: 05 Apr 2021 17:52 by klamos.

Please Log in or Create an account to join the conversation.

Moderators: HansU
Time to create page: 0.139 seconds
Powered by Kunena Forum