LinuxCNC Install using MX Linux 19.4 - Geared Toward New Users

More
08 Dec 2021 04:22 #228593 by rfrey
Thanks for this guide! I've run into a hitch, I wondered if anyone else had? When I clone mesaflash and run make, I get the error

"Makefile:61: ***"pkg-config can't find libcrypto". Stop."

I have libcrypto++6 and libcrypto++-dev installed.

Output from uname -a is
Linux novakon 4.19.0-18-rt-amd64 #1 SMP PREEMPT RT Debian 4.19.208-1 (2021-09-29) X86_64 GNU/Linux

Any pointers are greatly appreciated! I'm not sure where else this dependency might live. Openssl is also installed.
 

Please Log in or Create an account to join the conversation.

More
08 Dec 2021 16:28 - 09 Dec 2021 16:28 #228635 by snowgoer540
Thank you for bringing this to my attention.  I saw the resolution in the other thread.  I will update the build guide this evening. 

I broke the steps out in an effort to make everything easy and cohesive, but perhaps it's better to let new users follow the readme, so it stays up to date on its own.  I'll ponder it a bit after work.  

EDIT:  this change isn't committed yet, so I will just update my sheet in the meantime.  Once it's committed, maybe I'll point right to the readme file.

EDIT2: part 2 pdf was updated to add the dependency. 
Last edit: 09 Dec 2021 16:28 by snowgoer540.

Please Log in or Create an account to join the conversation.

More
12 Dec 2021 14:46 - 12 Dec 2021 14:48 #228923 by Kiddekanin
EDIT. Same question/problem as above.
Last edit: 12 Dec 2021 14:48 by Kiddekanin.

Please Log in or Create an account to join the conversation.

More
12 Dec 2021 14:52 - 12 Dec 2021 14:53 #228926 by snowgoer540
Seems like you may have an older version of the part 2 pdf, I just updated it 3 days ago.  

I added the dependency on sheet 9 (of part 2 version 2021-12-09). It should read:

sudo apt install libpci-dev libssl-dev pkg-config build-essential git


At any rate, you can fix it by entering this in a terminal window:
sudo apt install libssl-dev

and then proceeding from step 4 on.
Last edit: 12 Dec 2021 14:53 by snowgoer540.

Please Log in or Create an account to join the conversation.

More
03 Jan 2022 20:07 #230678 by kb8wmc
I am attempting to build a LCNC Simulator ONLY on an older Dell Ispiron 531S computer for a friend using MX Linux 19.4...I instead ended up installing the RT Preempt image as per instructions provided in PDF documents...

I followed the directions provided by in the PDF's which resulted in a completed installation of LCNC into MXLinux 19.4...All went well with the exception of update error as the "deb.debian.org" could not be resolved...I managed to fix that issue and complete the updates...I then installed the RT preempt image subsequently LCNC all went well...

I then started LCNC only to have the computer lock up totally and the monitor screen display freeze up with an unusual pattern...

I have determined to do a fresh install a minimalist MX Linux, but this time finding a different linux image for LCNC that will provide me with only a simulator...What I need information on is: which image to select and where to get it, the proper key from keyserver, and any/all other information which may be helpful and concurs with the PDF's install sections...If possible I would prefer to install the 2.8 version of LCNC...

Any help will be greatly appreciated...thanks in advance...

Mike

Please Log in or Create an account to join the conversation.

More
04 Jan 2022 09:59 #230739 by rodw

I am attempting to build a LCNC Simulator ONLY on an older Dell Ispiron 531S computer for a friend using MX Linux 19.4...I instead ended up installing the RT Preempt image as per instructions provided in PDF documents...

If possible I would prefer to install the 2.8 version of LCNC...

Any help will be greatly appreciated...thanks in advance...

Mike


If you only want V 2.8 on a sim, you might as well use the 2.8 iso.
Alternatively, you could try this
www.qtpyvcp.com/install/bullseye.html
to get V 2.8 from source, you should just type git checkout 2.8 after cloning linuxcnc
The following user(s) said Thank You: kb8wmc

Please Log in or Create an account to join the conversation.

More
04 Jan 2022 11:05 - 04 Jan 2022 11:06 #230746 by snowgoer540
Hi Mike, 

I recommend against using the 2.8 iso.  It seems you want to use package installs (since you mentioned the key server and upgrading), so I also recommend against using bullseye, as the buildbot is not building packages for that distribution currently.  

To answer your specific question, yes, you can use the install guide to install the 2.8 package as well.  Just make the changes outlined in the post below (which is from this thread, but these things just tend to get buried with other peoples erroneous/irrelevant recommendations).

forum.linuxcnc.org/9-installing-linuxcnc...sers?start=60#223134

As for the keys, they should be the same, if not, a quick search on the forum should yield different ones to try.
Last edit: 04 Jan 2022 11:06 by snowgoer540.
The following user(s) said Thank You: kb8wmc

Please Log in or Create an account to join the conversation.

More
15 Jan 2022 21:52 #231941 by NoWayBack
My source build of 2.8.2 on MX21 was pretty straightforward, once I worked through a few details. I'll give the 7i76e a spin once I get this machine down to the workroom.

Please Log in or Create an account to join the conversation.

More
18 Jan 2022 13:35 #232293 by D.L.
snowgoer540, please replace libssl-dev to libmd-dev, libcrypto was replaced to libmd:
github.com/LinuxCNC/mesaflash/commit/ac3...a4786cfba6cdfce38dab
The following user(s) said Thank You: tommylight, snowgoer540

Please Log in or Create an account to join the conversation.

More
18 Jan 2022 13:42 #232294 by snowgoer540
Done.  Thank you for the heads up, I really appreciate it!
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

Time to create page: 0.102 seconds
Powered by Kunena Forum