Installing LinuxCNC 2.8 on Debian 11

More
18 Dec 2021 13:36 #229397 by BigJohnT
I have Debian 11 installed and I'm not seeing any guides for installing LinuxCNC 2.8. Is there deb for Debian 11 or do I have to build one?

JT

Please Log in or Create an account to join the conversation.

More
18 Dec 2021 13:56 #229398 by tommylight
There is 90% chances the Buster version will work, give it a try.
buildbot.linuxcnc.org/dists/buster/
The following user(s) said Thank You: BigJohnT

Please Log in or Create an account to join the conversation.

More
18 Dec 2021 15:05 #229405 by BigJohnT
Error: Dependency is not satisfiable: libboost-python1.67.0

Guess I'll try and build a deb.

Hmm, no Python2 installed on Debian 11 either! I see it's still in the Debian 11 packages.

JT

Please Log in or Create an account to join the conversation.

More
18 Dec 2021 15:50 #229408 by BigJohnT
I guess I should build and install the master branch...

JT

Please Log in or Create an account to join the conversation.

More
18 Dec 2021 17:15 #229414 by tommylight

Please Log in or Create an account to join the conversation.

More
18 Dec 2021 17:42 #229417 by BigJohnT
I already have a running system however there was a link in that thread to his notes on building which will help.

Thanks
JT
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
18 Dec 2021 21:46 #229433 by rodw
This is a good summary of getting going on Bullseye (11)
www.qtpyvcp.com/install/bullseye.html
The following user(s) said Thank You: BigJohnT, gitin

Please Log in or Create an account to join the conversation.

More
19 Dec 2021 17:08 #229497 by BigJohnT
It was actually very easy to get LinuxCNC going on Debian 11.

Opened the Synaptic Package Manager and searched for linux-image and selected the latest RT image and installed. Next a reboot and your in the RT kernel.

Cloned the LinuxCNC repo. Open a terminal in the directory and did the following.
sudo apt update
sudo apt dist-upgrade

sudo apt install libudev-dev bwidget intltool libboost-python-dev libepoxy-dev libgl1-mesa-dev libgtk2.0-dev libgtk-3-dev libmodbus-dev libeditreadline-dev libtk-img libusb-1.0-0-dev libxmu-dev netcat python3-dev python3-xlib tcl8.6-dev tclx tk8.6-dev yapps2 asciidoc dblatex docbook-xsl dvipng groff imagemagick inkscape python3-lxml source-highlight w3c-linkchecker xsltproc texlive-extra-utils texlive-font-utils texlive-fonts-recommended texlive-lang-cyrillic texlive-lang-french texlive-lang-german texlive-lang-polish texlive-lang-spanish texlive-latex-recommended asciidoc-dblatex texlive-xetex

debian/configure
dpkg-checkbuilddeps

debuild -uc -us

Then right clicked on the deb and let Gdebi install it.

JT
The following user(s) said Thank You: arvidb, tommylight, gitin

Please Log in or Create an account to join the conversation.

More
19 Dec 2021 17:12 #229498 by BigJohnT
Oh yea I had to install mate-menu so I could uncheck then recheck all the CNC menu items so they would show up in the right place.

JT

Please Log in or Create an account to join the conversation.

More
20 Dec 2021 13:45 #229556 by BigJohnT
Or you can just download the deb and use Gdebi to install.

github.com/jethornton/emcd11

JT
The following user(s) said Thank You: tommylight, gitin

Please Log in or Create an account to join the conversation.

Time to create page: 0.129 seconds
Powered by Kunena Forum