update to 2.9 went wrong

More
23 Nov 2023 07:18 #286306 by pistrix
Hi Everyone. I updated my Linuxcnc from 2.8.4 to 2.9.1 but my setup (in gmoccapy) doesn't work anymore. I updated as per instructions and ran my ini as before but I guess I am either doing something wrong or I missed something. Attached is the report that I got.

Could someone please point me to a right direction. Many thanks.
Attachments:

Please Log in or Create an account to join the conversation.

More
23 Nov 2023 10:06 #286313 by rmu
Replied by rmu on topic update to 2.9 went wrong
2.8 uses python 2.7 whereas 2.9 uses python 3.

you need to look at /home/frezar/linuxcnc/configs/PrintNC/python/toplevel.py and related files and adapt or replace them with those from 2.9.

Please Log in or Create an account to join the conversation.

More
23 Nov 2023 11:01 - 23 Nov 2023 11:20 #286317 by pistrix
Replied by pistrix on topic update to 2.9 went wrong
Thank you. I did what you suggested before writing here but maybe I made a mistake somewhere... Let me try again.
Last edit: 23 Nov 2023 11:20 by pistrix.

Please Log in or Create an account to join the conversation.

More
26 Nov 2023 18:37 #286566 by pistrix
Replied by pistrix on topic update to 2.9 went wrong
I tried again and it works just fine. :)

Please Log in or Create an account to join the conversation.

Time to create page: 0.085 seconds
Powered by Kunena Forum