Gmoccapy Found an error

More
04 Dec 2022 19:57 #258524 by Golab
Hi everyone . My name is Tomek.
At the beginning I will admit that I am an absolute newbie in the topic of Linux.
I managed to install Debian 11 (bullseye) along with linuxcnc-uspace_2.10.0~pre0_amd64.deb.
When I run Linuxcnc (GMOCCAPY), windows with messages appear (I attach print screens to the post).
In the case of AXIS interface(GUI), everything is ok.I like gmoccapy's GUI.
I do not know what's going on. please help :) 

Linux pc21 5.10.0-19-rt-amd64 #1 SMP PREEMPT_RT Debian 5.10.149-2 (2022-10-21) x86_64
linuxcnc-uspace_2.10.0~pre0_amd64.deb
Attachments:

Please Log in or Create an account to join the conversation.

More
04 Dec 2022 20:53 #258531 by rodw
Replied by rodw on topic Gmoccapy Found an error
Could you please advise if you built from source? I am assuming you did if you are running bulseye.

I suspect this is due to Gmocappy expecting to find a X windows environment when the default Debian desktop environment uses Wayland so the expected files do not exist on your system.
You may get more cluses if you open a terminal windo and run linuxcnc from there as more error mesages will be displayed. Please share the output.

Could you try this to get rid of Wayland.
at a terminal type:
sudo apt-get install 
tasksel sudo tasksel
Select XFCE and install it
Logout back to the logon screen. Place your cursor in the password field and a cog will appear bottom right and select XFCE and login normally.
If the problem goes away well and good.
If it doesn't, then its missing some other dependency. I suspect this would be because the Gmocappy maintainers have not included all dependencies in the Linuxcnc .deb build system.

In either case, please report your issue here so th edevelopers can investigate.
github.com/LinuxCNC/linuxcnc/issues

It would be helpful

Please Log in or Create an account to join the conversation.

More
04 Dec 2022 21:33 #258534 by rodw
Replied by rodw on topic Gmoccapy Found an error
Actually, you could skip the tasksel and xfce and just try and logout and in again, but select "Gnome on Xorg"
I just did some tests and this works for me. Gnome does not load.
It will remember your settings.

Please Log in or Create an account to join the conversation.

More
05 Dec 2022 15:39 #258605 by Golab
Replied by Golab on topic Gmoccapy Found an error
It lives :)
Thank you Rodw.
I checked "Gnome Xorg" and everything is ok.

It seems the Weyland window system doesn't talk with Gmoccapy.

Please Log in or Create an account to join the conversation.

More
14 Jan 2023 11:22 - 14 Jan 2023 11:23 #261920 by HansU
Replied by HansU on topic Gmoccapy Found an error
Just for information:
When I did a fresh Bullseye install with only XFCE selected and build LinuxCNC 2.10 from source, I got the same error.

I had to
pip3 install pyopengl
sudo apt install libghc-glut-dev

to get Gmoccapy working. pyopengl is also necessary to run Axis.

Can we add this somehow to the dependency list?
Last edit: 14 Jan 2023 11:23 by HansU.

Please Log in or Create an account to join the conversation.

More
14 Jan 2023 12:04 #261930 by rodw
Replied by rodw on topic Gmoccapy Found an error
Seems like you also need to add this one to your list
sudo apt install  libgtksourceview-3.0-dev
​​​​​​
But you are not off the hook yet because gmocappy now is the only gui that will not work on wayland with this suggestion from Seb on this issue
github.com/LinuxCNC/linuxcnc/issues/2264
export PYOPENGL_PLATFORM=x11
 

You probably should raise an issue in github to get the dependencies fixed.
Attachments:

Please Log in or Create an account to join the conversation.

More
14 Jan 2023 12:38 #261936 by HansU
Replied by HansU on topic Gmoccapy Found an error
Hmm no, I didn't have to install libgtksourceview-3.0-dev. Maybe it was installed as dependency of libgtk-3-dev?

But you are not off the hook yet because gmocappy now is the only gui that will not work on wayland with this suggestion from Seb on this issue github.com/LinuxCNC/linuxcnc/issues/2264


 Yes I have seen this and also the issues on Bookworm. But I wanted to start at the beginning ;-)

Please Log in or Create an account to join the conversation.

More
14 Jan 2023 13:16 #261939 by rodw
Replied by rodw on topic Gmoccapy Found an error
No, that one seems to be a dependency of the one I installed. 
ref: packages.debian.org/bullseye/libgtksourceview-3.0-dev

Please Log in or Create an account to join the conversation.

Moderators: newbynobiHansU
Time to create page: 0.226 seconds
Powered by Kunena Forum