Need help with Parallel Port Setup. (ESTOP issue)

More
14 Sep 2020 14:16 #182084 by shadab
Hi,
We are working to retrofit a sherline VMC with linuxcnc/Pathpilot. We are using a 4 AXIS TB6560 Driver Board to control the machine.
I was following the tutorials provided by Sarah on how to configure the Pathpilot configs to work with a parallel port. I was able to make it work somewhat because whenever I am trying to jog X or Y axis using the keyboard, the machine will jog a bit and then I'm getting an ESTOP error. I suspect it is because of lack of debouncing the pin as we have directly connected pin 13 of PP to ground via a switch.

I have attached the image of the error for the reference. TB6560 board has 4 inputs for limit switches out of which we decided to use 3 for limit switches and 1 as an external ESTOP which is connected to parallel port pin 13. Can someone take a quick glance at our hal/ini files to see whether the estop input pin config is correct or not.

Also is there a way to bypass this pathpilot ext-estop? We don't want an external estop to PP we only want to use the software estop in the PP gui.

Thanks,
Shadab

File Attachment:

File Name: mill_pp.hal
File Size:6 KB

File Attachment:

File Name: mill_pp.ini
File Size:6 KB

File Attachment:

File Name: postgui_mi...m_pp.hal
File Size:5 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
14 Sep 2020 14:22 - 14 Sep 2020 14:24 #182087 by shadab
Was not able to attach image so adding an external link: imgur.com/a/LWoZ1rm
Last edit: 14 Sep 2020 14:24 by shadab.

Please Log in or Create an account to join the conversation.

More
15 Sep 2020 01:45 - 15 Sep 2020 01:45 #182170 by smgvbest
you're outputing the ESTOP not inputing it

setp parport.0.pin-01-out-invert 1
net estop-out => parport.0.pin-01-out

you need this on a input pin
Last edit: 15 Sep 2020 01:45 by smgvbest.

Please Log in or Create an account to join the conversation.

More
15 Sep 2020 06:48 #182188 by shadab
I thought estop-out was supposed to be an output estop signal to the driver board's EN pin. As you can see from the parallel port pin configuration for the stepper driver board's first pin is EN pin for all of the axis drives.

Attachment not found


Attachment not found



Parallel port pin 10,11,12 and 13 are inputs while rest all are outputs(from the perspective of the computer). Please correct me if I'm wrong, my assumption, from reading the original tutorial's HAL/ini files is that estop-out is output signal from LCNC to driver and estop-ext is external estop input from an external E-switch to LCNC.

Also can this be an issue of debouncing, I've read in some other forum posts and people seem to have this issue. I can jog the x and y axis for aboout 30 seconds before the ESTOP occurs. Is it possible to bypass this estop-ext? Is it something PathPilot can work without?

Thanks,
Shadab

Please Log in or Create an account to join the conversation.

More
15 Sep 2020 06:51 #182189 by shadab
I'm not able to view uploaded images for some reason, here's a link to images I was referring above imgur.com/a/ZBjY2GJ

Please Log in or Create an account to join the conversation.

More
15 Sep 2020 08:53 - 15 Sep 2020 09:09 #182193 by Aciera
What I see you have only connected parport.0.pin-13-in-not to a signal but not to any input pin? So it should not have any effect at all.

mill_pp.hal:
Warning: Spoiler!

postgui_custom_pp.hal

Warning: Spoiler!


[edit]

Try

net emc-enable <= parport.0.pin-13-in-not =>iocontrol.0.emc-enable-in
net estop-out <= iocontrol.0.user-enable-out => parport.0.pin-01-out

and comment out the others

PS I can't see any of your images. Have you attached png?

[edit 2]

You can run LinuxCNC without external ESTOP. However for safety reasons it is highly recommended to use an external emergenca button.
Last edit: 15 Sep 2020 09:09 by Aciera.
The following user(s) said Thank You: shadab

Please Log in or Create an account to join the conversation.

More
15 Sep 2020 11:27 #182209 by shadab
Thanks for the suggestion I tried to implement it. Disable the following lines:
net estop-out => parport.0.pin-01-out

net estop-out <= iocontrol.0.user-enable-out
net estop-out => iocontrol.0.emc-enable-in

net estop-ext <= parport.0.pin-13-in-not

I'm still getting the same error. If I disable all the estop lines I'm not getting any error and I'm able to run continuously. I'll check with my hardware team if there are any issues in the connection.

Please Log in or Create an account to join the conversation.

More
15 Sep 2020 12:47 - 15 Sep 2020 12:49 #182227 by Aciera

If I disable all the estop lines I'm not getting any error and I'm able to run continuously.


Not sure how you're able to get out of estop if you have all lines with iocontrol.0.emc−enable−in commented out? That needs to be active to get the gui out of estop.
Maybe attach the current config files.

[edit]
And have a look at parport.0.pin-13-in-not with the "hal-show" monitor to check if that is actually doing what it should.
Last edit: 15 Sep 2020 12:49 by Aciera.

Please Log in or Create an account to join the conversation.

More
15 Sep 2020 14:44 #182238 by shadab
net estop-out <= iocontrol.0.user-enable-out
net estop-out => iocontrol.0.emc-enable-in

In my recent post i forgot to mention only these two lines are active rest all are commented.. I will post the latest configs tomorrow asap.

Thanks,
Shadab

Please Log in or Create an account to join the conversation.

More
16 Sep 2020 06:54 #182388 by shadab
Hi David,
I have attached the files here. I'm able to home all three axis correctly and also the limit switches are working as expected.

File Attachment:

File Name: mill_pp_20...9-16.hal
File Size:7 KB

File Attachment:

File Name: mill_pp_20...9-16.ini
File Size:6 KB

File Attachment:

File Name: postgui_mi...9-16.hal
File Size:5 KB
Attachments:

Please Log in or Create an account to join the conversation.

Moderators: cncbasher
Time to create page: 0.174 seconds
Powered by Kunena Forum