It appears QtDesigner is trying to load the QtPyVCP widgets using a python vers

More
27 Feb 2024 00:07 #294560 by szl
Hello, I have a small questionWhen I execute the editvcp vcp command, an error is displayed:

ERROR: It appears QtDesigner is trying to load the QtPyVCP widgets
using a python version greater than 2.7, this is not supported.
Make sure that you have the correct version of the libpyqt5.so
file in /usr/lib/x86_64-linux-gnu/qt5/plugins/designer/, see the
Installation Trouble Shooting section of the QtPyVCP Documents for more info.
May I ask how to solve this problem?

Thank you!
 

Please Log in or Create an account to join the conversation.

More
02 Mar 2024 11:08 #294901 by andypugh
To run with Python3 it seems you might need to run the dev version of PyQTVCP.
www.qtpyvcp.com/install/index.html

Please Log in or Create an account to join the conversation.

More
02 Mar 2024 20:55 #294944 by rodw
Seems like you have not installed the latest version of qtpyvcp that is required with later versions of linuxcnc/debian

Please Log in or Create an account to join the conversation.

More
04 Mar 2024 12:35 #295127 by Lcvette
looks like you are trying to run the latest version of qtpytvcp on a older python2 linuxcnc install, they are not compatible.  you need to be on linuxcnc 2.9 or greater.

Please Log in or Create an account to join the conversation.

Moderators: KCJLcvette
Time to create page: 0.101 seconds
Powered by Kunena Forum