missing lib/python/qtvcp/designer

More
05 Apr 2022 16:19 #239356 by LearningLinuxCNC
I am trying to get started on editing QtDragon for a custom application. This is my first Qtvcp project. So I am trying to get it set up. I installed QtDesigner that looks to be working. However when I get to the python-module loading library I am running into an issue. I am missing the directory on the machine lib/python/qtvcp/designer in fact I don't have lib/python directory. I have lib/pyshared, lib/python2.6, lib/python2.7, lib/python3 and lib/python3.7 none of which have the /qtvcp/designer subfolders.

How do I go about getting the precompiled python-module loading library?

Thanks,

Jim

Please Log in or Create an account to join the conversation.

More
05 Apr 2022 18:45 #239368 by LearningLinuxCNC
I have found the files that I could not locate. They are located at the following location
/usr/lib/python2.7/dist-packages/qtvcp/designer/

there are options for 5.5 5.7 and 5.9 per the instructions.

It does not appear that I have any of those three installed on this machine. This machine is configured from the 2.8.0 iso.

After installing designer per the qtvcp instructions
[i]sudo apt-get install qttools5-dev-tools[/i]
[i]sudo apt-get install qttools5.dev[/i]

in designer and in synaptic package manager it appears the version of qt5 installed is 5.11.3

What is the appropriate version to install on debian buster?

Please Log in or Create an account to join the conversation.

More
06 Apr 2022 03:05 #239413 by cmorley
is there a file named install script in the qtvcp/designer folder?
There is a 5.11 library available but not released yet.
 
Attachments:

Please Log in or Create an account to join the conversation.

More
06 Apr 2022 13:01 #239440 by LearningLinuxCNC
Chris,

There is no file named script in the qtvcp/designer folder.

I downloaded your tar.gz file placed it in a folder called:

/usr/lib/python2.7/dist-packages/qtvcp/designer/x86_64/qt5.11

extracted it and copied it to:

/usr/lib/x86_64-linux-gnu/qt5/plugins/designer/libpyqt5_py2.so

opened designer and the widgets still don't appear.



 

Please Log in or Create an account to join the conversation.

More
06 Apr 2022 20:51 #239474 by LearningLinuxCNC
I installed all of the dependencies for building linuxcnc.

Now when I try to launch designer I get the following.
:~$ designer -qt=5
Traceback (most recent call last):
  File "/home/sboperator/.designer/plugins/python/qtvcp_plugin.py", line 22, in <module>
    from qtvcp.plugins.simplewidgets_plugin import *
ModuleNotFoundError: No module named 'qtvcp'
Segmentation fault

Please Log in or Create an account to join the conversation.

More
07 Apr 2022 00:48 #239489 by cmorley
If you are running a compiled RIP version of linuxcnc you need to run:
. scripts/rip-environment
before running designer.

I thought you were using an installed version of linuxcnc in which you don't need to do that.
The error message seems to indicate it doesn't find qtvcp.
In a terminal can you run the command 'qtvcp' and see what it says?

Please Log in or Create an account to join the conversation.

More
07 Apr 2022 01:35 #239494 by LearningLinuxCNC
This is an installed version from 2.8.0 iso.

I downloaded all build dependencies today so I could build a kinematics module. I had issue with that also. It is in another post.

When I run qtvcp i get the following
:~$ qtvcp
[QtDesigner][INFO] Logging to "/home/sboperator/qtdesigner.log" (logger.py:88)
[QTvcp][INFO] Logging to "/home/sboperator/qtvcp.log" (logger.py:88)
[QTvcp][INFO] Base log level set to 20 (logger.py:52)
[QtDesigner.QTVCP.QT_PSTAT][DEBUG] BASENAME dummy (qt_pstat.py:58)
[QtDesigner.QTVCP.QT_PSTAT][DEBUG] Checking for handler file in: /home/sboperator/dummy_handler.py (qt_pstat.py:78)
[QtDesigner.QTVCP.QT_PSTAT][DEBUG] Checking for default handler file in: /usr/share/qtvcp/panels/dummy/dummy_handler.py (qt_pstat.py:84)



 

Please Log in or Create an account to join the conversation.

More
07 Apr 2022 01:36 #239495 by LearningLinuxCNC
And the rest because the forum would not let me put this all in one post. . .
[code][QtDesigner.QTVCP.QT_PSTAT][INFO] No handler file found (qt_pstat.py:90)
[QtDesigner.QTVCP.QT_PSTAT][DEBUG] Checking for .ui in: /home/sboperator/dummy.ui (qt_pstat.py:104)
[QtDesigner.QTVCP.QT_PSTAT][DEBUG] Checking for .ui in: /usr/share/qtvcp/panels/dummy/dummy.ui (qt_pstat.py:109)
[QtDesigner.QTVCP.QT_PSTAT][CRITICAL] No UI file found - Did you add the .ui name/path? (qt_pstat.py:116)


[QtDesigner.QTVCP.QT_PSTAT][ERROR] Available built-in VCP Panels: (qt_pstat.py:125)
cam_align
sim_panel

[/code]

Please Log in or Create an account to join the conversation.

More
07 Apr 2022 01:38 #239496 by LearningLinuxCNC
Designer was opening earlier before downloading the build dependencies. Now it will not open.

Please Log in or Create an account to join the conversation.

More
07 Apr 2022 05:34 #239502 by cmorley
Did you copy this file to here or use a system link (should be a system link)?

/home/sboperator/.designer/plugins/python/qtvcp_plugin.py

Here is the install script (unzip it) maybe that will be easier.

Chris
 
Attachments:
The following user(s) said Thank You: LearningLinuxCNC

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.109 seconds
Powered by Kunena Forum