EMC_JOG_STOP Error and error logging

More
13 May 2022 00:13 #242833 by drose
Error:
command (EMC_JOG_STOP) cannot be executed until the machine is out of E-stop and turned on.

Summary:
I have a machine which is running on a Pi4 using a software step-gen to communicate with two servo drives. The machine runs fine when running a program and jogging in the software normally. When we add an xbox controller to control the machine jog, the machine will intermittently return the error shown above (EMC_JOG_STOP) and require a software restart to become operable again. 
Xbox setup:


Troubleshooting steps:
So far to debug this issue I've:

- Gone through the HAL step-by-step to isolate the issue, which appears to only trigger while jogging the machine with the controller
- Scope the step-gen pins on the pi to find that they send out several rapid pulses right before triggering the error
- Tried to traceback the error through the source-code but have had trouble narrowing it down.
     - The error appears to be triggered whenever LinuxCNC runs into some kind of error state triggered by some other error.

Any ideas what could be triggering this or where this error could come from? Is there a way to turn on error logging in LinuxCNC so that all the exceptions raised in the source-code are written to a logfile? 
 

Please Log in or Create an account to join the conversation.

More
14 May 2022 00:05 #242923 by andypugh
Literally the problem seems to be that something is sending a jog-stop command _after_ something else has triggered the E-stop.

Does the machine act like it is e-stopped when this happens?

(Have you tried F1 F2 to clear e-stop and re-start?)

Please Log in or Create an account to join the conversation.

Time to create page: 0.061 seconds
Powered by Kunena Forum