Spindle Encoder Count Negative

More
06 Dec 2022 15:36 #258709 by COlger81
I've been off of the mill for a while so i'm a bit rusty with LinuxCNC configs. The last issue i need to resolve is that my spindle encoder counts are counting backwards when spindle is rotating clockwise. I changed the sign for the encoder scale in the INI but it is still counting backwards. Any help is appreciated.

Chris

Please Log in or Create an account to join the conversation.

More
06 Dec 2022 16:42 - 06 Dec 2022 16:43 #258718 by scotth
Try swapping A phase and B phase on the encoder.
Last edit: 06 Dec 2022 16:43 by scotth.
The following user(s) said Thank You: COlger81

Please Log in or Create an account to join the conversation.

More
06 Dec 2022 17:15 #258721 by andypugh
Making the scale negative really ought to have worked.

Please Log in or Create an account to join the conversation.

More
06 Dec 2022 18:07 - 06 Dec 2022 18:39 #258723 by COlger81
I agree, but it did not. Swapping A and B phase did fix the encoder count direction but i'm seeing erratic behavior when testing rigid tap. RPM sign, position, and encoder count is reading correctly now. The index is a hall sensor directly on spindle shaft and also verified that is functioning in halshow.

VFD is a hitachi WJ200. The best i'm able to get the drive to respond to for minimum RPM is 20. Not sure if that's going to work..

If anyone has a verified reliable VFD they can suggest with linuxcnc i'm all ears. Not all that happy with this hitachi.
Last edit: 06 Dec 2022 18:39 by COlger81.

Please Log in or Create an account to join the conversation.

More
06 Dec 2022 19:01 #258726 by andypugh
I am so sure that it ought to work that I think that there is a possibility that you edited the wrong file, or that the scale is being set in more than one place.

Please Log in or Create an account to join the conversation.

More
06 Dec 2022 19:21 #258728 by COlger81
Definitely edited the correct file. Where else could it be set? Oh well, swapping phases fixed that issue.

Please Log in or Create an account to join the conversation.

More
06 Dec 2022 20:07 #258735 by PCW
Replied by PCW on topic Spindle Encoder Count Negative
Its possible to have a value in an ini file that is either unused in hal or over written by a hal statement. I think this is the most likely reason changing
the scale number had no effect.

Please Log in or Create an account to join the conversation.

More
06 Dec 2022 20:34 #258737 by COlger81
Any ideas on why the rigid tapping isn"t functioning properly? Encoder is counting properly and the index is functioning as it should through halshow.

Please Log in or Create an account to join the conversation.

More
07 Dec 2022 20:54 #258832 by COlger81
The problem is resolved and i am now able to rigid tap.

Much appreciated!

Please Log in or Create an account to join the conversation.

Time to create page: 0.166 seconds
Powered by Kunena Forum