controller is not executing commands in sequence

More
14 Nov 2023 23:49 #285443 by southbayguy
Hi --
     I have v. 2.8.4 installed on a three-axis router.
     I make a craft product using the router for surfacing.  The machine creates a 3D surface in wood.  The ballnose cutter is moving in X, Y and Z.
     For finish cuts, I take a series of cuts where the machine is moving only in X and Z, starting at the right hand end of the workpiece and cutting to the left, climb cutting for a nice finish.  When the pass is finished and the cutter is at the left hand edge of the piece, there is a
G0 Z.2 command to lift the cutter clear, then it rapids X+ (and a little Y+) to get into position for its next pass.
     After running fine for several weeks, my machine started behaving incorrectly.  It began its X+ move to get over for its next pass BEFORE it had completed its G0 Z.2 move, marking the workpiece and busting the cutter.  It has never done this before.
     In all the years I have been making these parts on this machine, I have never set G64 and it has behaved fine.  It rounds corners a little bit but not much.  Nothing like this.
     I have been trying to find a workaround.  There is room to cut air off the left hand side of the workpiece so I have tried to take advantage of that.
     I have tried the following (instead of G0 Z.2):

G0 G91 X-1. Y-.4 Z1.
G0 G91 X-1. Y.4 Z1.

     I'm trying to give the control room to mess up in a way that won't trash my part.  Give it two tries to come up above the part, and give it extra distance up.
     As a person who has operated CNC mills most of my working life, I am disconcerted by watching the machine ignore the Z command and chug out on the diagonal, doing the G91 X-1. Y-.4 part of the command, ignoring Z.  Then making up for the lost Z movement some time later in the sequence.
     It's as if the machine has a mind of its own.
     This behavior after weeks of working correctly.
     I'm stumped.
     Thanks in advance for any ideas.
     I've tried putting G64 P.0001 Q.0001 in the program preamble.  After a few passes, the machine returns to its bad tricks.
     Behavior is different if I slow the feedrate way down, but my workpieces require hundreds of these finishing passes in XZ.  I'm hoping for a better workaround than way-reduced feedrate.
 

Please Log in or Create an account to join the conversation.

More
15 Nov 2023 13:24 #285509 by andypugh
is there any chance that the Z axis is slipping? Either mechanically or by missing steps?
Typically this would be pretty obvious, but could be masked if there is a tool-length measurement routine.

You could try videoing the screen (the DRO) during the cycle to see if the observed motion matches the DRO numbers. This would allow you to differentiate between a mechanical problem and a controller problem.

Please Log in or Create an account to join the conversation.

Time to create page: 0.202 seconds
Powered by Kunena Forum