1st move after using eoffset violates machine acc and vel limits...

02 Jan 2024 16:36 - 03 Jan 2024 14:21 #289575 by Henk
HI. I ran into an issue with a new machine config where i use eoffsets as part of the tool change operation. It seems that the first move after a toolchange violates the machine acceleration and velocity limits. If i run the same code without the M6 T14 line, it works as expected. I verified this by looking at a halscope plot of joint3.position-cmd, which clearly shows a step change of 85 degrees at line 12 (G30 IS AT B=90)

(DRILL2 2)
N1 g54
N2 g64p0.02
N3 M9
N4 M1
N5 G30
N6 M101     ;high gear
N7 G4 P1
N8 T14 M6
N9 S1500 M3
N10 G54
N11 G54
N12 G0 B5. C-90. 
N13 m2

The background is complicated, but here are some details that i think contributes to this issue.
Why do i use external offsets during toolchange? Because of this issue:  github.com/LinuxCNC/linuxcnc/issues/246#issuecomment-423049528
And i need to move the Z axis of the machine to remove and insert tools while doing a toolchange. I wrote a custom comp to handle the toolchange, which at the right state enables eoffset on the Z axis. comp attached. The comp also handles the orientation, since m6 cancels orient (verified in a sim config) If there are any other details required to help me understand this issue, please let me know, for now i am not sure which way to go apart from adding a workaround in my cam post by adding small incrimental moves after toolchanges.  Ini and .comp file attached  (note that i set the ferror limits to large values while still trying to solve this issue) Thanks and Happy new Year! Henk
Last edit: 03 Jan 2024 14:21 by Henk. Reason: fixed hyperlink

Please Log in or Create an account to join the conversation.

03 Jan 2024 14:31 #289661 by andypugh
External offsets are _meant_ to stay inside machine limits, so this particular case sounds like a bug, and should probably be reported as such.

Please Log in or Create an account to join the conversation.

04 Jan 2024 10:00 #289748 by Henk
HI Andy
I was also convinced that this is a bug, but not so sure anymore.

I set up a sim config and wrote a simple comp to offset the z axis during a toolchange, and move it back again before signalling tool-changed.

I dont see the same behaviour as on my actual machine, and it works as it is supposed to work.

puzzled, have to think about this a bit more...

Please Log in or Create an account to join the conversation.

Time to create page: 0.059 seconds
Powered by Kunena Forum