FERROR on Z with float switch

More
19 Apr 2011 01:02 #9070 by jcizek
I am having a problem with a Following Error on my Z axis. Using a modified set of the thc300 configs. The manual says:

The concept of a following error is funny when talking about stepper motors. Since they are an open loop system, there is no position feedback to let you know if you actually are out of range.

following errors usually have 2 causes on steppers

1. too little ferror or min_ferror

2. the RT pulsing can't keep up with the speed needed

2.a. BASE_PERIOD set incorrectly or (requested step rate is not possible at this BASE_PERIOD)

2.b. max velocity too high

2.c. max acceleration too high


So I used FERROR from one of my other (working) configs and is set to 0.05.

Is it simply set to low? I get the error *instantly* when trying to turn the spindle on (which on the THC300 config as best I can tell should be pushing the Z axis down until it hits the float switch, then up to the pierce height, then turn on the torch)
I can jog the Z axis by with the buttons or my jog pendant with no errors, so I assume my acceleration and velocity are not the problem?

Thanks!!

Please Log in or Create an account to join the conversation.

More
19 Apr 2011 12:19 #9076 by BigJohnT
If the THC is not lying to EMC about the Z position when it moves the axis you will get a following error. In my THC comp for the Mesa THCAD card the commanded position from EMC is hijacked in the THC comp. However the THC comp always reports back to EMC the commanded position as the current position. I don't know anything about the THC300 but it was a shot in the dark that something similar is going on.

John

Please Log in or Create an account to join the conversation.

More
19 Apr 2011 13:57 #9079 by jcizek
Hmm, I don't know if I am fully understanding you here. What do you mean by "lying to EMC"? In a stepper based system, there basically isn't any feedback to EMC as to where any axis actually is, correct? On this THC, it's very basic, the THC knows nothing about the Z axis. The Z limit comes in
through the first parallel port card (as does the X and Y limits, as well as the step and direction OUT for X Y and Z) and then the Float switch input,
and "move up" , "move down", and "arc ok" outputs FROM the THC into EMC come into a second parallel port (with a second BOB) The BOB's are
braindead BOB's that do nothing more than split the signals out, there are no "smarts" (and in this case, not even isolated).

It kind of sounds like in your case the THC is reporting back Z position to EMC? I don't know anything about the mesa cards, but I am correct in guessing that they are servo based and not stepper?

and after re-reading your post, I wanted to explain that I am getting the FERROR instantly when trying to either fire the torch (spindle on) OR executing any Gcode, the THC hasn't even come into play yet. I hear the Z axis stepper make about 1 step (maybe a 1/2 step since i am setup in 1/2 step driver) and then I get the FERROR. So basically, even if i just hit the spindle on (torch on) button in manual mode, the Z stepper clicks and I instantly get the FERROR. Does that clear anything up?

Thanks John, -James

Please Log in or Create an account to join the conversation.

More
19 Apr 2011 14:34 - 19 Apr 2011 14:34 #9084 by BigJohnT
EMC still wants position feedback even with a stepper system. Usually it is just a loop back from position commanded to position feedback. So my comp just tells EMC what it wants to hear that the position commanded = position feedback. The Mesa THCAD card is just a voltage to frequency converter, a way to get tip voltage into EMC so the THC is part of EMC.

Turning the spindle on should not cause the Z axis stepper to move in any way so there is something wrong for sure. Try setting the ferror up enough to see if it moves a couple of steps or a half a turn or something when you turn on the spindle/torch.

John
Last edit: 19 Apr 2011 14:34 by BigJohnT.

Please Log in or Create an account to join the conversation.

More
19 Apr 2011 18:44 #9108 by jcizek
OK, Set FERROR much higher (5.0) and tried again. When I hit the spindle (torch on) button, the Z axis comes racing downwards at some unimaginable speed and makes it down a ways before the error pops up.

Looking at the flow chart included with the THC300 sample configs, it looks like when emc receives a torch on command (either from G code or the manual button on the AXIS interface) then first thing it does is enter what I will call the "touch and go" loop. It starts the Z axis down and waits for the FLOAT switch activation, then raises to pierce height + float switch height, THEN fires the torch and waits for an ARC OK signal. It does not simple just fire the torch. There appears to be a closed HAL loop that needs to complete for the torch fire command to complete.

That being said, I can't figure out why the Z axis is diving at such an incredible rate. I have the max velocity in the ini file set to 1.0 (i use inches, not metric)
and Max accel set to 30. When the axis homes itself, if appears to be homing at the 1.0 inch setting, but turning on the torch is causing the axis to search for FLOAT at some very high velocity. I can't find any other settings in any of the other hal files or the ini file that would control that speed.

I also can't seem to find ANY documentation on any of those sample plasma configs, in the python script that sets up the extra sidebar, I see a few menus setup, for Switch Travel, Travel Height, and Step Size, but I can't find any docs as to what these values do or mean. I *assume* that step size is how far your Z axis moves per step (though I don't see why this is relavent if that's really what it is since the THC just says "move one way until I see the correct voltage again" and is unaware of how far it will be moving the axis). Switch travel seems like it's probably the distance the z axis moves to activate the float switch?? by since this is fixed, i don't know why it would be a menu item? and I don't have a guess on travel height. Maybe my assumptions are way off on these items too, if there were any docs it would be very helpful to self educate!

In any case, I think there must be something I am missing in config for the Z axis velocity while searching for Float switch input... Any ideas?
Thanks! -James

Please Log in or Create an account to join the conversation.

More
19 Apr 2011 19:10 - 19 Apr 2011 19:19 #9115 by BigJohnT
I'm as lost as you are maybe more on that config. When you get it figured out maybe you could write something up on it.

A max velocity of 1.0 is 1.0 inches per second! So that is 60 IPM try setting it to some real low number till you sort it all out.

www.linuxcnc.org/docview/html/config_ini_config.html#sub:[DISPLAY]-section

John
Last edit: 19 Apr 2011 19:19 by BigJohnT.

Please Log in or Create an account to join the conversation.

More
20 Apr 2011 15:04 #9167 by jcizek
I have gotten in touch with Jarl about this issue. He has answered several of my questions about the config already and made a suggestion to slow down the Z axis during the probe period. I have a question still pending to him about an independent velocity control during probe. I'll post back here as I have any new info. Thanks!! -James

Please Log in or Create an account to join the conversation.

More
20 Apr 2011 21:50 #9204 by jcizek
OK, so a little more testing done now.

If I set FERROR *very* high, like 90+ inches, then I see a new behavior, the "probing" is actually partially working as it's supposed to. When I trigger the torch on, the Z axis comes down to find the material top, when the float switch is activated, Z reverses and comes up. I still have the velocity problem, Z is coming down WAY too fast (I have set MAX VELOCITY to 0.1 as suggested). The axis homes at the barely crawling speed, but when probing, still comes down extremely fast. It is however seeing the float switch input and reversing to raise the torch. The new problem is that it's reversing the Z axis and sending it up until it hits the limit switch!! ;-)
So I still am waiting to hear from Jarl if there is a velocity setting I am missing somewhere that controls probing velocity, but I am now chasing the problem of figuring out how to have the Z raise to the appropriate place and stop before firing torch.

This is getting quite frustrating, but I just can't see using Mach3 as an answer, EMC2 seems SO superior to it!!
Any ideas welcome, otherwise, I'll post more if/when I learn more! Thanks. -James

Please Log in or Create an account to join the conversation.

More
20 Apr 2011 22:15 - 20 Apr 2011 22:18 #9205 by BigJohnT
Does the THC300 have "control" of the Z axis? Or just what does the THC300 do?

Is the sample g-code file in metric like with a huge F compared to an inch file?

There is no doubt that EMC is great. :)

and did you know the THC300 is a metric config?

John
Last edit: 20 Apr 2011 22:18 by BigJohnT.

Please Log in or Create an account to join the conversation.

More
20 Apr 2011 22:33 #9206 by jcizek
The THC watches the tip voltage and sends "up" and "down" signals to EMC2 to move the Z axis. The THC doesn't have any direct control of the axis. The THC has up and down signals that it sends to EMC, as well as ARC OK signal. The fire torch signal comes from EMC and goes into the THC, and then the THC in turn closes a relay to fire the torch in the plasma. Those are the only signals in or out. EMC does most of the THC internally (like watching X and Y velocities and height and corner locking when velocity falls below a threshold) Really the only function of this THC is the voltage measurement and sends the up and down sigs to EMC via pins on the 2nd parallel port.

No, the Gcode i have been playing with are all in inches, generated with sheetcam. I haven't really been messing with Gcode much since the manual spindle button will duplicate the problem. Figure that gcode will work fine once the problem with the probing loop is solved!!

-James

Please Log in or Create an account to join the conversation.

Time to create page: 0.760 seconds
Powered by Kunena Forum