Milling Program Execution

More
25 Mar 2020 19:19 #161482 by Chipmunk
Hello Forum, I am experiencing a problem with the execution of a milling program., First of all my DXF drawing is developed using Turbo Cad 12.and the output is in inches. The program used to develope the code for Linux CNC is Cut2D. The output is also in inches.. I am using Linux CNC with Ubuntu 10.04 LTS. The problem I am experiencing is a size reduction in the CNC output. My stock is 3.5 x 5.5 inches The output from Linux cnc covers about 1/4 of an inch. I have looked at the Linux CNC measurement and confirmed that it is also in inches..I have run the splash screen and it follow the Linux name perfectly. I have used this combination of programs since I bought the machine and this is the first time that I have run into this problem. Have you folks any ideas as to what is causing this ?

Please Log in or Create an account to join the conversation.

More
25 Mar 2020 19:36 #161491 by rodw
Replied by rodw on topic Milling Program Execution
Some DXF files are dimensionless so there is nothing to tell if it is in inches or mm. It looks like your post processor is outputting in millimetres. Does it have a setting to force the units to inches?

Please Log in or Create an account to join the conversation.

More
25 Mar 2020 19:50 #161492 by Chipmunk
Replied by Chipmunk on topic Milling Program Execution
I cant say for sure that this is not the case .I feel as well that the output is in MM and I will have another look at the outputs.Thanks for your thoughts.

Please Log in or Create an account to join the conversation.

More
25 Mar 2020 20:07 #161497 by tommylight
Check at the start of the gcode for G20 or G21.
G20 = inch
G21 = mm

Please Log in or Create an account to join the conversation.

More
25 Mar 2020 20:13 #161500 by Chipmunk
Replied by Chipmunk on topic Milling Program Execution
Thank You I will look into this this evening

Please Log in or Create an account to join the conversation.

More
26 Mar 2020 01:31 #161526 by Chipmunk
Replied by Chipmunk on topic Milling Program Execution
I spent some time with my mill this evening , for some unknown reason without intervention on my part it performed the program perfectly. The product dimensions were as drawn in Turbo cad. I do not know what happened to correct the fault
Thank You Folks for taking the time to help me with my problem..

Please Log in or Create an account to join the conversation.

Moderators: piasdom
Time to create page: 0.079 seconds
Powered by Kunena Forum