× Forum Header

simulation mode

More
22 Sep 2018 01:37 #117859 by kccheng
simulation mode was created by kccheng
Hi,

This is first time I try to use LinuxCNC. I have a DIY CNC made by 3 old floppy drives.
Since the XYZ can go only from 0 to 15mm only, I want to have a bigger CNC
in simulation mode use the same configuration. So I use stepconf to create
the configuration, this time, in simulation mode.
But, when I start linuxcnc, I got the following error message:

sim_hardware.hal:37: parameter or pin 'parport.0.pin-06-out-invert-fake' not found

I'm running linuxcnc v2.7.14. Any help is appreciated. Thanks a lot.

Regards
KC

Please Log in or Create an account to join the conversation.

More
22 Sep 2018 11:12 #117864 by tommylight
Replied by tommylight on topic simulation mode

sim_hardware.hal:37: parameter or pin 'parport.0.pin-06-out-invert-fake' not found

Fake ????
It can be true or false.

Please Log in or Create an account to join the conversation.

More
22 Sep 2018 12:25 #117866 by kccheng
Replied by kccheng on topic simulation mode

sim_hardware.hal:37: parameter or pin 'parport.0.pin-06-out-invert-fake' not found

Fake ????
It can be true or false.


The file, sim_hardware.hal, was genereated by 'stepconf' automatically.
That's why I'm asking ....

Please Log in or Create an account to join the conversation.

More
22 Sep 2018 16:02 #117868 by cmorley
Replied by cmorley on topic simulation mode
looks like a possible bug with the simulated parport component.

can you post your stepconf file?

Chris M

Please Log in or Create an account to join the conversation.

More
22 Sep 2018 16:22 #117869 by cmorley
Replied by cmorley on topic simulation mode
as a quick check, go to the file, sim_hardware.hal and any line like:
(just out-invert-fake)

parport.0.pin-06-out-invert-fake 1

change to :

parport.0.pin-06-out-invert 1

see if that works.
Chris M

Please Log in or Create an account to join the conversation.

More
22 Sep 2018 16:40 #117870 by kccheng
Replied by kccheng on topic simulation mode

looks like a possible bug with the simulated parport component.

can you post your stepconf file?

Chris M


Attachments is "floppy-sim.stepconf".
The following is error messages:

$ linuxcnc floppy-sim/floppy-sim.ini
LINUXCNC - 2.7.14
Machine configuration directory is '/home/kccheng/linuxcnc/configs/floppy-sim'
Machine configuration file is 'floppy-sim.ini'
Starting LinuxCNC...
.
Found file(REL): ./floppy-sim.hal
sim_hardware.hal:37: parameter or pin 'parport.0.pin-06-out-invert-fake' not found
Shutting down and cleaning up LinuxCNC...
LinuxCNC terminated with an error. You can find more information in the log:
/home/kccheng/linuxcnc_debug.txt
and
/home/kccheng/linuxcnc_print.txt
as well as in the output of the shell command 'dmesg' and in the terminal
Attachments:

Please Log in or Create an account to join the conversation.

More
22 Sep 2018 17:08 #117872 by kccheng
Replied by kccheng on topic simulation mode

as a quick check, go to the file, sim_hardware.hal and any line like:
(just out-invert-fake)

parport.0.pin-06-out-invert-fake 1

change to :

parport.0.pin-06-out-invert 1

see if that works.
Chris M


With that change, I can start LinuxCNC. But when I do "Home All"
I got error message:

How switch inactive before start of latch move.

parport.0.pin-06-out-invert
is my Z-Direction pin, it's the only inverted pin.
The Z axis is reversed (home at top, Z+ goes down).


Regards,
KC

Please Log in or Create an account to join the conversation.

More
22 Sep 2018 17:31 #117873 by kccheng
Replied by kccheng on topic simulation mode
Since I want to setup a simulation CNC, I realize that don't really need to mimic the
hardware configuration of my real floppy CNC.

Here is some tests I did for v2.7.14:

1) stepconf

At the start page, if I choose "Modify a configuration already created with this program"

I still need to check "Create simulated hardware configuration" !! If this checkbox is not checked, the simulation mode in the previous configration file will be overrided as FALSE.


2) remove the invert PIN.

So the LinuxCNC can start normally (the inverted PIN is buggy)
But click "Home All" will cause error.

3) remove the HOME pin

LinuxCNC now can run without any problem.
However, the the "Home All" button become "Home Axis" and I can only Home one axis at a time !!!


Regards,
KC

Please Log in or Create an account to join the conversation.

More
22 Sep 2018 21:55 #117879 by cmorley
Replied by cmorley on topic simulation mode
So that seems to indicate more then one problem.
output Pin wrong name ( we know how to fix that one )

sounds like homing input is inverted.
I wonder if this is caused by the hardware default logic vrs software simulation of the parport not being the same?

can you post your stepconf file again but compressed? the forum only allows me to open it in firefox not download it.

Chris M

Please Log in or Create an account to join the conversation.

More
23 Sep 2018 01:35 #117890 by kccheng
Replied by kccheng on topic simulation mode
Here is the Zipped configuration file.
Compare it with my real floppyCNC configuration file, there are on 2 different tag
as following:

<property name="machinename" type="string" value="floppy-sim"/>
<property name="sim_hardware" type="bool" value="True"/>



Regards,
KC
Attachments:

Please Log in or Create an account to join the conversation.

Time to create page: 0.180 seconds
Powered by Kunena Forum