Trouble with LAN setup on new PC install (Wheezy 7 / LCNC 2.7.14 )

More
18 Dec 2021 22:46 #229445 by Jake
Does anyone have any good guide to get the LAN setup on a new Wheezy 7 install? 
I am getting my butt kicked on this one.  I actually had a Dell Optiplex 9020 that I was able to install everything on.  With the newer LAN setup on this one I see the "LO' in the network setup, but no " enp0s3 "  the old setup showed " eth0 " for the ethernet connection.  So it seems as it is not seeing the network connection or LAN port. 

when I use the command cat /etc/network/interfaces

I only get back the

auto lo
iface lo inet loopback

no primary network interface.  I can not seem to figure out where to get this setup. 

Any pointers ? 

Thanks !

Please Log in or Create an account to join the conversation.

More
18 Dec 2021 23:07 #229449 by tommylight
ip a
?
or maybe
ifconfig -a
?
FYI, Mesa ethernet or ethercat will not work with a RTAI kernel that comes with Wheezy. They require RT-Preempt kernel.

Please Log in or Create an account to join the conversation.

More
19 Dec 2021 00:57 #229459 by PCW
Its possible Wheezy is too old to support the Ethernet hardware on a newer PC

Please Log in or Create an account to join the conversation.

More
19 Dec 2021 02:03 #229462 by Jake
Well that would not be cool. I can download the latest and greatest. I can see the Ethernet controller from lspci -v

The machine is 10 ish years old.....I went from the 15-16 year old machine to this one.

I am using Pico PPMC ( which I'm battling parallel port on the other thread...) This install is beating me.

Please Log in or Create an account to join the conversation.

More
19 Dec 2021 02:05 #229463 by Jake
IP a only shows LO, no additional Ethernet

Please Log in or Create an account to join the conversation.

More
19 Dec 2021 03:29 #229465 by Jake
I dumped wheezy and installed buster. It fixed it self once I got past the CD-ROM work around. Network connection is happy. I don't know. Thanks everyone!
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

Time to create page: 0.084 seconds
Powered by Kunena Forum