Why G-code is generated twice with different Z ?

More
20 Apr 2012 01:41 #19385 by yello
Why G-code is generated twice with different Z ?

I did some 2D with draftSight on Xp and used a tool to generate the G-Code - however, in LinuxCNC I can see that the the code is generated twice with different Z value. Why is that and how can I prevent it? Or better, how can I modify it and add more Z layers in case I have a thick workpiece?

On this video at around 2:36 you can see what I mean, it also runs the mill distance twice.

Please Log in or Create an account to join the conversation.

More
20 Apr 2012 07:23 #19387 by cncbasher
no video link , so i can only guess at this stage

code generation is done from the gcode cam generator , LinuxCNC does not generate the code , it acts upon it ...
but what you may be seeing is the offset tool path , i.e the origional generated gcode path and then the actual path the tool takes to produce

which cam program are you using to produce the gcode ?
the cut depth of the z axis is set in your cam program .

post a drawing and your gcode and we can advise

Please Log in or Create an account to join the conversation.

More
20 Apr 2012 10:17 - 20 Apr 2012 10:18 #19390 by yello
Was the youtube link removed? If so I don't want to post it again. So just go to youtube and search for "How to make a simple gcode" - the video I mean is from zkazka123 (not mine).

I used this time GSimple (on Xp), but the effect is the same. Now I like to remove the 2nd layer, but later I may want to add more layers in case I have thicker material.



File Attachment:

File Name: bjoern2.ngc
File Size:0 KB
Attachments:
Last edit: 20 Apr 2012 10:18 by yello.

Please Log in or Create an account to join the conversation.

More
20 Apr 2012 11:03 #19393 by cncbasher

Please Log in or Create an account to join the conversation.

More
20 Apr 2012 11:11 #19394 by Rick G

Why G-code is generated twice with different Z ?


Depending on the program that generated the tool path if you need to cut say 1/2" thick and you have a setting of a maxium cut depth per pass of say 1/4" the program will generate two tool paths,
one at 1/4" deep and then a finish cut of 1/2" deep.

To avoid this either set your maxium cut at 1/2" or your depth at 1/4" deep or less.

Rick G

Please Log in or Create an account to join the conversation.

More
23 Apr 2012 07:31 #19452 by yello
whoops, I guess wrong file format. I like to investigate it a bit further myself. Certainly my error somewhere.

Please Log in or Create an account to join the conversation.

Time to create page: 0.114 seconds
Powered by Kunena Forum