Radius to end of arc differs from radius to start error

More
20 Jun 2019 15:18 - 20 Jun 2019 15:57 #137390 by shogan50
I ran this part program a few days ago with out issue. Now I get this error. Any help appreciated. LINK TO SCREEN SHOT OF ERROR Something is causing it to think it is starting at x110.2089 on line N70.
%
(RAPIER)
(T1  D=12.7 CR=0. - ZMIN=-22.55 - FLAT END MILL)
N10 G90 G94 G17 G91.1
N15 G21
N20 G53 G0 Z0.
(PARALLEL2)
N25 M9
N30 T1 M6
N35 S18000 M3
N40 G54
N45 M8
N50 G0 X217.826 Y-32.099
N55 G43 Z15. H1
N60 G0 Z1.
N65 G1 Z0.27 F3000.
N70 G18 G3 X216.557 Z-1. I-1.27 K0.
N75 G1 X210.019 Z-1.004
N80 X-116.054 Z-8.635
N85 G3 X-117.354 Z-7.365 I-0.03 K1.27
N90 G0 Z5.
N95 X-184.161 Y-25.755
N100 Z-8.228
N105 G1 Z-8.929 F3000.
N110 G2 X-182.861 Z-10.198 I1.27 K0.
N115 G1 X210.019 Z-1.004
N120 X216.557 Z-1.
Last edit: 20 Jun 2019 15:57 by shogan50.

Please Log in or Create an account to join the conversation.

More
20 Jun 2019 15:23 #137391 by shogan50
BTW, I tried to attach a file several times, but it timed out and I lost my post. The file was within size limits. A larger version is linked in the original text.

Two possible relevant items. I accidentally typed a G10L10P1X0Y0Z0 rather than a G10L20. I've not done much with the machine or ini file in between. Feels like some modal setting. I've read the posts on radii tolerance, but this is off by 100mm.

Please Log in or Create an account to join the conversation.

More
20 Jun 2019 21:42 #137420 by shogan50
No one has responded, but for those who might encounter in the future, I'm pretty sure I figured it out. I won't know for sure until I get home and test, but N55 turns on cutter compensation after the G0 move on N50. If I did indeed type G10L10P1X0Y0Z0, then there are X and Y offsets in the tool table and my money is that the magnitude of X is about 106.4mm. The post processor didn't anticipate non-zero x and y offsets in the tool table.
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
20 Jun 2019 22:25 #137427 by tommylight
Usually that error is for to big tool for a small radius, or something wrong with offsets, or trying to start an arc at an inconvenient position.

Please Log in or Create an account to join the conversation.

More
23 Jun 2019 23:50 #137681 by shogan50
That was indeed it the problem.

Please Log in or Create an account to join the conversation.

Time to create page: 0.079 seconds
Powered by Kunena Forum