G64 not read properly in RS247NGC_STARTUP_CODE

More
24 Nov 2023 11:15 #286392 by piflixe
Hi there,

somehow, the G64 is not activated properly in the startup code.

My startup code reads like

RS247NGC_STARTUP_CODE = G17 G21 G40 G49 G64P0.1Q0.2 G80 G90 G92X0Y0Z0 G94 G97

I also tried

RS247NGC_STARTUP_CODE = G17 G21 G40 G49 G64 P0.1 Q0.2 G80 G90 G92X0Y0Z0 G94 G97

with the same result

By the way, I find the default behavior with having a value that large that the machine runs with full speed around corners not ideal. I would rather expect that the machine would run in exact stop mode if &4 is not explicitely activated.

Anyone have a clue how to set it properly in the startup code in the ini?



 

Please Log in or Create an account to join the conversation.

More
25 Nov 2023 15:22 #286466 by CNC_ANDI
Did you test it with a NC Programm without G64 P0.01 Q0.02?

What did the machine do with a nc programm G64 P0.01 Q0.02 included?

Please Log in or Create an account to join the conversation.

More
25 Nov 2023 21:20 #286501 by cmorley
What version of linuxcnc?

Please Log in or Create an account to join the conversation.

More
26 Nov 2023 15:55 #286556 by piflixe
I am using the current 2.8.4 stable release

Please Log in or Create an account to join the conversation.

More
26 Nov 2023 18:14 #286563 by piflixe
Without the G64 command in the NC program the machine makes a big radius at every corner. Can't remember where, but I read somewhere that the default or a G64 without any parameters tells Linuxcnc to make the corner round enough to go around with the current speed. Especially on machines with high speeds and / or low acceleration this makes for big radii.

I can clearly see the radii in the trajectory history in linuxcnc. First I thought it might be a problem with the servo drives.

When G64 is used in a NC program it works nicely and exactly like described in the documentation.

However, it seems not to be enabled by the startup g code. It also resets after a restart of linuxcnc. So the settings do not get saved permanently.

Please Log in or Create an account to join the conversation.

More
26 Nov 2023 18:49 #286568 by rodw

I am using the current 2.8.4 stable release

The current version is 2.9.1. It is on the downloads page. Perhaps the issue is resolved.
It is much safer to set the preamble in the gcode file

Please Log in or Create an account to join the conversation.

More
27 Nov 2023 03:41 #286601 by cmorley
In 2.9 g64 is set by default to a much more reasonable number.
But as Rod mentioned anything can override the setting.

Please Log in or Create an account to join the conversation.

More
27 Nov 2023 07:29 #286607 by piflixe
Oh, I have missed the release of 2.9.1 as stable linuxcnc version. Can't wait to upgrade!

Thanks for the remarks. I will test it once I have upgraded.

However, did anyone test including G64 in the startup code and verified it is actually processed correctly?

Please Log in or Create an account to join the conversation.

More
27 Nov 2023 13:54 #286621 by cmorley
open linuxcnc's status program and look at 'settings', the last two numbers are g64 P and Q numbers

Please Log in or Create an account to join the conversation.

More
27 Nov 2023 21:18 #286639 by radom
remember when you toggle F2 in axis you lose your g64
so having it in startup_code I find it imho useless

Please Log in or Create an account to join the conversation.

Time to create page: 0.132 seconds
Powered by Kunena Forum