Axis 3D view not updating occasionally (LinuxCNC 2.9)

More
13 Oct 2021 02:49 #222995 by MRx
Hi,

does anyone have experience with the LinuxCNC code? the 3D UI is not updating occasionally, I start a project and in order to update the 3d view I need to click into the 3d widget and drag the window around.
The milling procedure itself is okay and there are no issues.
Something's not triggering a proper update it seems.

Before I start looking at the code, I wonder if anyone has experience with that part of linuxcnc?

Please Log in or Create an account to join the conversation.

More
13 Oct 2021 10:55 #223016 by tommylight
If you mean the preview window or Gremlin as it is named, chances are the PC has issues with OpenGL functionality, some older Intel chipsets had serious issues with that.

Please Log in or Create an account to join the conversation.

More
13 Oct 2021 23:33 #223047 by MRx
I don't think it's opengl driver related because if I move the mouse it refreshes.
I tried to reproduce it but I'm still not able to .. it just happens randomly and usually at some point at the beginning

Please Log in or Create an account to join the conversation.

More
14 Oct 2021 15:30 #223088 by andypugh
If you start LinuxCNC from the command line you might be able to see some diagnostic information in the terminal when the problem happens.

(Just open a terminal and type "linuxcnc")

Please Log in or Create an account to join the conversation.

Time to create page: 0.130 seconds
Powered by Kunena Forum