invalid parameters in linear command

More
29 May 2022 10:24 #244110 by sibelius
Hi everyone

How things are going? 

Today after a while I start to run a job on my machine and for the first time I got this warning :"invalid parameters in linear command" just after a tool change.
After I manually change the tool and press enter to confirm the change I got this warning and the machine froze.
Any help would be great.
Thanks in advance
 

Please Log in or Create an account to join the conversation.

More
31 May 2022 13:03 #244282 by andypugh
I think this probable means that the tool length has been set incorrectly and the machine is being commanded to move the tool tip to somewhere that it can't physically reach.

The machine shouldn't freeze, though. It should just stop executing the program.

Have a look in the tool table for unexpectedly large values (especially ones in X and Y that should not be there)

Please Log in or Create an account to join the conversation.

More
01 Jun 2022 03:06 #244340 by sibelius
Thank Andy for your reply

Yes the machine stopped executing the program.
This morning I've tried to repeat the job and I did not experience any problem, so I don't know.
I probably did something different the time before without realizing, anyway your reply is good because now I know what the probable cause of the problem is.

Thank again for your help
V.

Please Log in or Create an account to join the conversation.

Time to create page: 0.061 seconds
Powered by Kunena Forum