Homing with prox and index no longer working

More
13 Jul 2010 21:20 #3344 by jimmyservo
The CNC desktop mill that I am building is using EMC2.3.5. Here are the other machine specs:
Computer: Dell Dimension 4600 Pentium 4 at 3.2 GHz
System Memory: 512MB DDR SDRAM
Hard Drive: 4GB Transcend IDE Flash Module
Interface: Pico Systems PPMC (ENC, DAC, DIO)
Motors: Yaskawa SGM-0xA31x series (100, 200, 400 watt)
Drives: Yaskawa SGDA-0xAS series
Limit / Home Switches: AutomationDirect CR8-AN-2F prox switch NPN normal open

So here is my question: Homing worked fine using Max Limit as Home and the Index pulse, but ever since upgrading to EMC2.3.5 it doesn't work. I understand that "linksp" and "newsig" have been replaced by "net" in the ppmc_io.hal file, and assigning multiple signal names (like Xmaxlim AND Xhome) to a single pin is now treated as an error. How do I translate my old ppmc_io.hal file?

newsig Xminlim bit
newsig Xmaxlim bit
newsig Xhome bit
linksp Xminlim <= ppmc.0.din.01.in-not
linksp Xminlim => axis.0.neg-lim-sw-in
linksp Xmaxlim <= ppmc.0.din.02.in-not
linksp Xmaxlim => axis.0.pos-lim-sw-in
linksp Xhome <= ppmc.0.din.02.in-not
linksp Xhome => axis.0.home-sw-in

Thank you!
jimmyservo

Please Log in or Create an account to join the conversation.

More
13 Jul 2010 22:09 #3346 by robh
would become

net Xminlim axis.0.neg-lim-sw-in <= ppmc.0.din.01.in-not
net Xmaxlim axis.0.pos-lim-sw-in <= ppmc.0.din.02.in-not
net Xhome axis.0.home-sw-in <= ppmc.0.din.02.in-not

i hope this helps, and i hope i got this right

robert

Please Log in or Create an account to join the conversation.

More
13 Jul 2010 23:07 - 13 Jul 2010 23:28 #3347 by jimmyservo
Thanks for the quick reply!
Yes I tried this already, EMC will not even start up because it sees one pin (ppmc.0.din.02.in-not) with more than one signal name (Xmaxlim and Xhome). It puts up an error message.
This was no problem with older versions, but for some reason ("net" ?) it now is a problem.
The integrator's manual says there are 4 kinds of homing (with a very nice diagram!) and by my count 9 *.ini entries.
I've tried every combination that I could think of, but I would much rather know what I'm doing and why.
Here's my present ppmc.ini entry relating to homing (the one that used to work fine):

HOME = 1.0
HOME_OFFSET = 2.0
HOME_SEARCH_VEL = 0.8
HOME_LATCH_VEL = 0.2
HOME_FINAL_VEL = 0.4
HOME_USE_INDEX = YES
HOME_IGNORE_LIMITS = YES
# HOME_IS_SHARED = 0
# HOME_SEQUENCE = 1

"Home switch active before start of latch move" is as close to functional as I have been able to get. Any ideas?
Regards, jimmyservo
Last edit: 13 Jul 2010 23:28 by jimmyservo. Reason: used # instead of * in file type

Please Log in or Create an account to join the conversation.

Time to create page: 0.096 seconds
Powered by Kunena Forum