Rules problem - XHC pendant naming - Resolved!!

More
20 Mar 2021 13:22 #202974 by Muzzer
Rules problem? was created by Muzzer
I am trying to understand why my xhc-whb04b-6.hal file isn't doing the business with my WHB04L pendant.

I have created a 99-xhc-whb04b-6.rules file containing this string:
ATTR{idProduct}=="eb70", ATTR{idVendor}=="10ce", MODE="0666", OWNER="root", GROUP="plugdev"

But when I try to talk to the pendant, I get this message:
muzzer@LinuxCNC:~$ xhc-whb04b-6 -ue
init starting in simulation mode
init usb context ... ok
init not waiting for device XHC-WHB04B-6 vendorId=0x10ce productId=0xeb93, will continue in 0s ......

It doesn't seem to be taking notice of the rules file. Is there another place where it is being defined or have I made a silly typo somewhere?

I can get the pendant to generate output OK if I run the older xhc-hb04.hal using the same rules string.

Thanks

muzzer@LinuxCNC:~$ lsusb
Bus 001 Device 004: ID 10ce:eb70 Silicon Labs
etc

Please Log in or Create an account to join the conversation.

More
20 Mar 2021 15:21 - 20 Mar 2021 16:19 #202989 by Muzzer
Replied by Muzzer on topic Rules problem?
Hmmmph. It seems that the rules files are not actually used. I can remove them without preventing the older xhc-hb04 version from working. I'm guessing the issue may lie elsewhere.

Are the product and vendor IDs hard coded in the component?

EDIT - I think I hear the sound of several pennies dropping. I have a 4 axis pendant but the xhc-whb04b-6 component is specific to the 6 axis pendant. I'm sure that is stated clearly somewhere.

If I'm right, I need to be rewrite parts of my hal and ini files to implement the older 4 axis component. The way it is implemented is quite different, so it looks like a lot of work. Ah well, I'm learning as I go!
Last edit: 20 Mar 2021 16:19 by Muzzer.

Please Log in or Create an account to join the conversation.

More
21 Mar 2021 16:38 #203131 by Muzzer
I will call it a day on this now. To my mind, much of the confusion arises from the pendant naming scheme. My current XHC wireless USB pendant is an older model (dating from 2014) and is identified as an "HB04-L". It looks pretty clunky compared to the current pendants being made by XHC.

The current pendant is sold as the "WHB04B-6" and referred to by that name here, presumably because it is often sold as a 6 axis device. There is a 4 axis version "WHB04B-4" that seems to be almost identical.

The drivers for these pendants are the XHC-WHB04B-6 linuxcnc.org/docs/2.8/html/man/man1/xhc-whb04b-6.1.html for the modern pendant and XHC-HB04 linuxcnc.org/docs/2.8/html/man/man1/xhc-hb04.1.html for the older model. If, like me, you persisted in trying to drive the older pendant with the newer driver, you may find you were barking up the wrong tree. They both appear to be "HB04" pendants but those last few digits are critical...

I have neither the brain power nor the stamina to recreate my HAL and INI files from scratch for the older pendant, so have caved in and ordered the modern WHB04B-6 pendant. The example HAL file in the WHB04B-6 manual page appears to be pretty clear and it coxists with my current setup without errors. On a good day, the new pendant would bring it to life - time will tell!

There's a great deal of confusion over these things and the forum is full of all manner of seemingly relevant but frustratingly tangential content. It also seems to be fairly simple to connect a pendant up to a sim but the last little steps to get a real system working have proven deceptively difficult. I've learnt a lot in the past week or so and I'm sure some of it will prove to have been useful in the long run.

Please Log in or Create an account to join the conversation.

More
25 Mar 2021 21:51 #203646 by Muzzer
Just to confirm, my XHC-WHB04B arrived today and worked straight out of the box with the example hal file. I had to set up the 99-xhc-whb04b-6.rules file but that was all. I now have my lathe axes moving under pendant control.

Simple lesson - if you purchase the correct wireless pendant and follow the correct instructions, it will work pretty much straight out of the box. I think we can call it a day.

Many thanks to the guys who put in the work to make this happen!
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

More
31 Jul 2021 20:10 #216484 by Archidea
I also have the same issue "init not waiting for device XHC-WHB04B-6"
I have the 6 axis version, XHC-WHB04B-6
(Linux linuxcnc 4.9.0-13-rt-amd64 #1 SMP PREEMPT RT Debian 4.9.228-1, Linux Mint 19.3, linux 2.8
I have created a 99-xhc-whb04b-6.rules file, copied into /etc/udev/rules.d
lsusb doesn't show the device
Am I missing something or the usb stick is defective?

Please Log in or Create an account to join the conversation.

Time to create page: 0.075 seconds
Powered by Kunena Forum