controlling emco tool changer

More
20 Feb 2012 09:04 - 20 Feb 2012 09:11 #17853 by ArcEye
Hi again

loadrt hal_parport cfg="0x378 0xac00 out " # out not in manual. ????

linuxcnc.org/docs/html/hal_parallel_port.html#parallel%20port section 1.1.1.2

Normally you would want to use loadrt hal_parport cfg="0x378 out 0xac00 in "
because it is extra input that is required so pins 2-9 are switched to input

addf parport.1.reset base-thread #Not in manual. Should it be here????????

Could not immediately track down the manual entry re this, as I understand it the reset is used when driving steppers, so unless you have a 5+ axis machine unlikely to need it on 2nd port

Now about half the time, I get "RTAPI: ERROR: unexpected real time delay on task 1" when I start emc

Classic latency error, need to do a long latency test then tune and eliminate any problems.
wiki.linuxcnc.org/cgi-bin/wiki.pl?TroubleShooting section 4 for starters

If you have already done this and it was working OK before all your changes, try setting base period to higher figure in the .ini file.
You might have been skating on the absolute bottom limit of what you could set the figure to without errors and adding a couple more things to the thread pushed it over

I normally start with a figure 3 times the base thread max from the latency test and tune from there.

regards
Last edit: 20 Feb 2012 09:11 by ArcEye.

Please Log in or Create an account to join the conversation.

More
20 Feb 2012 09:15 #17854 by Rick G
You might want to look here for reset...
linuxcnc.org/docs/html/hal_parallel_port.html#r1_1_4
Here is some info on adding a 2nd par port...
linuxcnc.org/docs/html/examples_pci_parallel_port.html
which seems to indicate that reset may not be needed in your case.
You may also want to retest your computer for latency.

Rick G

Please Log in or Create an account to join the conversation.

More
20 Feb 2012 18:08 #17873 by chuck1024
I made some minor changes to the parallel port hal lines such as removing the reset and associating the out with the first parallel port.
I still get the error when starting emc.

I removed all parallel port 1 references and the error went away.

I ran stepcon wizard and changed jitter from 19000 to 22000 and the error only showed up the first time
and I had the address wrong in the loadrt command. I tried many times with the correct parallel port setup and the error did not appear.

So it appears that I am running on the harry edge. Ironicly I have been using the computer on a 3 axis mill for several years with the latency set at 17k without a problem. In the past I tried installing a video card and the numbers got worse. The video card changed the video from onboard APG to PCI. I have the max speed set at 60 IPM so increasing the jitter numbers probably won't affect operation. In case it matters this machine is still running Linux 8.04

I will probalby bump the latency up a bit more and call it good.
cs

Please Log in or Create an account to join the conversation.

Time to create page: 0.089 seconds
Powered by Kunena Forum