Tool change problems - Help

More
10 Sep 2013 08:08 #38584 by DaOne
Maybe someone could look at my hal / classic ladder and tell me why I cant seem to get a tool change complete back from classic ladder? Gotta be something simple. I also notice that not all relays reset every time. Maybe something I need to do differently? Here is my code. This is a hydraulic turret changer.
Attachments:

Please Log in or Create an account to join the conversation.

More
10 Sep 2013 21:39 - 10 Sep 2013 21:43 #38622 by BigJohnT
It's not good practice to use the same output more than once. I see TUnclamp7 3 times and 2 are Resets.

Take a look at my ladder for my Hardinge here:
gnipsel.com/shop/hardinge/hardinge.xhtml

It's better to use latching rungs to control logic flow.

I find it helps to first write out the sequence of events in plain words then translate that to ladder.

JT
Last edit: 10 Sep 2013 21:43 by BigJohnT.

Please Log in or Create an account to join the conversation.

More
10 Sep 2013 22:40 #38626 by DaOne
Replied by DaOne on topic Tool change problems - Help
Thanks JT,

One thing I can not figure out is even if I do a straight through call from toolchange request to tool change complete in the first rung I still don't seam to get a toolchange complete. The toolchange request contact is still help on. Any idea why? I got lots to learn on this still and I am slowly figuring things out as I go. Thank you for your help.

Please Log in or Create an account to join the conversation.

More
11 Sep 2013 00:10 #38633 by BigJohnT
I thought I was losing my mind but I found it and the Classicladder examples as well... there is a turret example that runs as a sim so you can watch the rungs as you toggle the inputs.

gnipsel.com/linuxcnc/ladder/index.html

JT

Please Log in or Create an account to join the conversation.

More
12 Sep 2013 10:33 #38681 by DaOne
Replied by DaOne on topic Tool change problems - Help
Works!



Tell me what you think of the new code?

File Attachment:

File Name: my_LinuxCN...9-11.zip
File Size:11 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
12 Sep 2013 17:44 #38690 by BigJohnT
I assume you mean HSLathe.clp? It looks very familiar to me. The main thing it that you got it to work.

JT

Please Log in or Create an account to join the conversation.

Time to create page: 0.097 seconds
Powered by Kunena Forum