MODBUS TCP/IP ERRORs

More
26 Oct 2010 14:43 #4876 by 315john
MODBUS TCP/IP ERRORs was created by 315john
Hello

I am using EMC2 and classic ladded to talk to a GE-30 PLC over modbus TCP/IP. I can write to the registers. My problem is that i keep getting a Modbus error screen with no information from classic ladder and sometimes will loose my communication all together until i restart emc. Everything worked great talking to the modbus PLC simulator.....

Can anyone help?

John

Please Log in or Create an account to join the conversation.

More
26 Oct 2010 23:52 #4888 by 315john
Replied by 315john on topic Re:MODBUS TCP/IP ERRORs
I determined that the problems came from the cross over from the PLC simulator to the 90-30. I did not have the 1st modbus element loaded with the correct number

Please Log in or Create an account to join the conversation.

More
28 Oct 2010 00:58 #4918 by cmorley
Replied by cmorley on topic Re:MODBUS TCP/IP ERRORs
Could you describe exactly how you use TCP ?
I could never get it to work.

Please Log in or Create an account to join the conversation.

More
28 Oct 2010 12:42 #4927 by 315john
Replied by 315john on topic Re:MODBUS TCP/IP ERRORs
Yes i would be more than happy to help you... could you send me and example of what you are trying to connect to

Please Log in or Create an account to join the conversation.

More
29 Oct 2010 06:14 #4956 by cmorley
Replied by cmorley on topic Re:MODBUS TCP/IP ERRORs
Well Classicladder actually can be set up as a slave.
But A modbus simulator would be good too.

Please Log in or Create an account to join the conversation.

More
29 Oct 2010 14:24 #4962 by 315john
Replied by 315john on topic Re:MODBUS TCP/IP ERRORs
I am working on putting a little doc together for you

Please Log in or Create an account to join the conversation.

More
31 Oct 2010 00:07 #4974 by 315john
Replied by 315john on topic Re:MODBUS TCP/IP ERRORs
Here is a PDF i put together to help you out. Let me know if you need anything else.

Please Log in or Create an account to join the conversation.

More
31 Oct 2010 00:09 #4975 by 315john
Replied by 315john on topic Re:MODBUS TCP/IP ERRORs
hmm didnt work. i can email it to you

Please Log in or Create an account to join the conversation.

More
31 Oct 2010 01:37 #4976 by andypugh
Replied by andypugh on topic Re:MODBUS TCP/IP ERRORs
Could you Wikify it? The EMC2 Wiki at wiki.linuxcnc.org/cgi-bin/emcinfo.pl is publicly editable. You just need to follow the instructions here: wiki.linuxcnc.org/cgi-bin/emcinfo.pl?BasicSteps to prove you are not a 'bot.

Please Log in or Create an account to join the conversation.

Time to create page: 0.077 seconds
Powered by Kunena Forum