setting the workpiece 0 point

21 Aug 2023 16:09 #278624 by geostein8888
so my lathe seems to do now what it should.
now i run into the next problem.
In Fusion the workpiece diameter is set 20mm.
When i now open the nc file in fusion, go to the outer corner of the work piece on the right end and make a touch off x and z, every thing looks fine; but when i start the program the tool is working in the air around 5mm in x away from the work piece, z looks correct.
Did i understood the touch off wrong here - is my first Lathe job, i worked up to now only with cnc routers.
is there a description on how to work with linuxcnc and lathe, i only could find the configuration manuals


Please Log in or Create an account to join the conversation.

21 Aug 2023 17:20 #278628 by andypugh
Here is how I work.
(some of these steps only need doing once, or until I press the wrong touch-off button).

Tool 1 is a turning and facing cutter (WNMG insert). That always has a tool length of 0 in both X and Z.

I use that to turn a piece of material to diameter, and then measure that to set the machine (G54 etc) diameter.

M6 T1 G43,

I then (generally) set the machine Z to just inside the stock, and make a facing pass. The end of the stock is now at the current machine zero in Z.

M6 T2 G43

Then I measure the Z offset of my next tool by jogging close to the newly-faced end, and jogging away until a 6mm dowel slips through the gap. Then set the _tool_ Z to 6mm.
Then turn a diameter, measure it, set the tool X to the measured value.



Now all tools are set to a true diameter, and I can set the workpiece Z with any tool, as the system knows the tool length.

Just don't forget to set the tool, and apply the tool offsets (G43) first.

Most lathes don't require G43. There are ways to make LinuxCNC not require it either.

Please Log in or Create an account to join the conversation.

Moderators: piasdom
Time to create page: 0.064 seconds
Powered by Kunena Forum