7i76e Start Up Error

More
30 Nov 2021 02:41 #227974 by thefabricator03
Hi Guys,

I am having an issue with my 7i76e on start up, I am getting the following error messages. I have not changed anything from the other day when I was last using the machine.

 
Attachments:

Please Log in or Create an account to join the conversation.

More
30 Nov 2021 09:29 #227986 by tommylight
Replied by tommylight on topic 7i76e Start Up Error
Change the 5V supply.
Was there any storm last night near you?
Or use a USB cable for testing only.

Please Log in or Create an account to join the conversation.

More
30 Nov 2021 20:16 #228069 by PCW
Replied by PCW on topic 7i76e Start Up Error
Those errors look to be real time related
I would run a latency test and stress the machine

Sometimes a hardware failure on the host PC can
cause latency issues
The following user(s) said Thank You: thefabricator03

Please Log in or Create an account to join the conversation.

More
30 Nov 2021 20:57 #228071 by thefabricator03
Thanks PCW,

I have run a latency test and the numbers are very high. What can I do about the latency? The machine was working fine last week. Although to answer Toms question, yes we did have a storm last Friday when the machine was still turned on. Could the 7i76e be fried?

I did switch out the 24v power supply to the 7i76e with a new power supply and I am still getting the error messages.

Please Log in or Create an account to join the conversation.

More
30 Nov 2021 21:58 - 30 Nov 2021 21:58 #228072 by PCW
Replied by PCW on topic 7i76e Start Up Error
I think the problem is latency, not sure what changed
but may be bad/failing harddrive (I have seen this
make latency much worse)

How bad is the latency?

latency-histogram --nobase --sbinsize 500
Last edit: 30 Nov 2021 21:58 by PCW.

Please Log in or Create an account to join the conversation.

More
30 Nov 2021 22:25 #228077 by thefabricator03
PCW,

Please see attached screenshots. How bad is that latency?
 
 
Attachments:

Please Log in or Create an account to join the conversation.

More
30 Nov 2021 22:37 #228081 by PCW
Replied by PCW on topic 7i76e Start Up Error
15 MS! (about 50X what the worst case should be)

The system must have "upgraded" your
kernel to a non-realtime version since
the kernel listed by the latency-histogram
is a stock kernel.
The following user(s) said Thank You: thefabricator03

Please Log in or Create an account to join the conversation.

More
30 Nov 2021 22:46 #228083 by tommylight
Replied by tommylight on topic 7i76e Start Up Error
I agree with PCW, so boot the PC from a USB with LinuxCNC, open the existing config from the hard drive and check if it works, or just test latency.
The PC has a lot of stuff that will mess latency, from a failing power supply to failing memory controller, but the hard drive is the most common offender.
BTW, the 24V will not impact latency and comms with the card, 5V can and will mess up the comms.
I might have jumped the gun here, but i had a 5V issue lately on a machine built by someone else, and after over 30 times of me telling him to get a high quality 5V supply he got some 5 Euro ones that look the same as some Delta ones, took some time to figure out he got counterfeits!
The following user(s) said Thank You: thefabricator03

Please Log in or Create an account to join the conversation.

More
30 Nov 2021 22:47 #228084 by tommylight
Replied by tommylight on topic 7i76e Start Up Error
I just saw the histogram ... sorry .

Please Log in or Create an account to join the conversation.

More
30 Nov 2021 22:50 #228085 by thefabricator03
Ok, so maybe one of my operators has selected an update notification when operating the machine. I cant get that information out of them - all they know is they did not do anything!

Thank PCW, I will reinstall the RT version and see how I go.

Please Log in or Create an account to join the conversation.

Moderators: PCWjmelson
Time to create page: 0.269 seconds
Powered by Kunena Forum