7i96s first setup issue - CR6 red light

22 May 2023 13:01 - 22 May 2023 13:05 #271928 by stavy
Hi,It’s my first time installing LinuxCNC after receiving lately my new 7i96s mesa board, I tried to use Mesa Configuration Tool by JT (mesact) when I am loading up the configuration CR6 is immediately turn on red light and nothing happen, I will explain all my steps I did so far:
  1. Installed LinuxCNC 2.8.4, Debian 10 (buster) on a HP ProDesk 400 g5 desktop mini.
  2. Connect 5DC to the board.
  3. Connect LAN and successfully ping it through
  4. In the Configuration Tool installed 7i96s_d firmware and verified it using the Verify button.

In picture ‘1.png’ – how I made the connections.

‘2.jpg’ – General look on my board, maybe jumpers not set correctly? STEP/DIR 0 connected incorrectly?

‘3.jpg’ – What happens after I fire up my configuration, immediately when it’s open Gmoccapy GUI.What can cause those problems? Maybe I need to connect 3 stepper drivers XYZ and not only X? Maybe an emergency button is needed to be wired?

Note – I tried also with AXIS and an error occurred – hm2/hm2_7i96s.0: error finishing read

I really could have some advice here, kinda lost here  
Last edit: 22 May 2023 13:05 by stavy.

Please Log in or Create an account to join the conversation.

22 May 2023 13:59 #271934 by PCW
The red light indicates a watchdog bite.

The "hm2/hm2_7i96s.0: error finishing read"is the cause
This means too many sequential Ethernet data packets have been
dropped because of excessive delays.

This can be for several reasons

1. System latency too high.
Normal fixes are:
Disable all power management and speed switching in the BIOS
(C states >C1, turbo modes/speed step etc)
Check by running the latency-test or latency-histogram:
latency-histogram --nobase

2. Network latency is too high:
Normal fixes are:
If you have a Intel MAC on you host PC, make sure you disable IRQ coalescing
(this is described in the hm2_eth manual page: man hm2_eth)
Using a newer Kernel
Lowering the servo thread rate

Check the network latency with:
sudo chrt 99 ping -i .001 -q
(stop with control C after a minute or so to print stats)

Please Log in or Create an account to join the conversation.

22 May 2023 15:12 #271941 by stavy
It worked! I disabled all the power management nonsense…
 I ran the test you recommended, the results are good?

Thanks for the help!!! 

Please Log in or Create an account to join the conversation.

Moderators: PCWjmelson
Time to create page: 0.122 seconds
Powered by Kunena Forum