stuck on z axis

More
16 Aug 2019 01:55 #142302 by alexone
stuck on z axis was created by alexone
I wanted to test my Z physical limits so without homing, i moved on both ends of my Z axis slowly until it stopped. All was good, but i left the machine on the upper Z limit for about 20 minutes and when i came back, any command on the Z axis would enter the machine in E-STOP and show the error:"Cannot unhome while moving, joint 2.I'm using LinuxCNC software.
I tried changing the movement speed, home-all command and i get the same result. If i move down on the Z axis very slow, the controller shows the Z lowering, but in reality it doesn't move and after about 2-3mm of virtual movement, it errors again.
All the other axes are working.
Any advice? Any idea what's wrong?
Is it dangerous to hit the limit switches? Is hiting the limit switches something i should never do?

Thanks!
The following user(s) said Thank You: Todd Zuercher

Please Log in or Create an account to join the conversation.

More
16 Aug 2019 02:34 #142303 by Todd Zuercher
Replied by Todd Zuercher on topic stuck on z axis
Is it possible the axis is physically stuck? Did the drive error out and shut down and need reset?

Please Log in or Create an account to join the conversation.

More
16 Aug 2019 02:39 #142304 by alexone
Replied by alexone on topic stuck on z axis
I'm really new to cnc and linuxCnc, so I have no idea. All I know is that I restarted the machine, I pressed the reset button from the command panel, nothing works...

How can I reset the drive?
If it's physically stuck I don't know how to unstuck it. It's massive and it's pneumatic. It uses air to move.

Please Log in or Create an account to join the conversation.

More
22 Aug 2019 16:46 #142856 by andypugh
Replied by andypugh on topic stuck on z axis
If homing is configured then the machine can normally be got off of the limit switches by homing it.
Though this is not necessarily always the case.
You probably need to click the "ignore limits" box to get the machine to turn on to allow homing or jogging off the limit.

A sightly risky way to get of the limits os to disconnect the limit switch input in the HAL layer. You can do this at the command line with something like
halcmd unlinkp joint.0.pos-lim-sw-in
(You need to know which limit is being trippe,d and which joint) But once you have jogged off the limit you should stop the machine and re-start with the unmodified config.

I am a bit confused by the error message given, though. You are not trying to unhome, after all.

Please Log in or Create an account to join the conversation.

Moderators: cncbasher
Time to create page: 0.082 seconds
Powered by Kunena Forum