MPG count going mad

More
02 Aug 2018 23:08 #115469 by andypugh
Replied by andypugh on topic MPG count going mad
I think this should fix the problem.

github.com/LinuxCNC/linuxcnc/commit/42d0...09a74bb43daf85c23611

Please update to the latest build and see. I appreciate that it will take a while to be sure.

Please Log in or Create an account to join the conversation.

More
03 Aug 2018 03:08 #115480 by OT-CNC
Replied by OT-CNC on topic MPG count going mad
Andy,

Thanks for working on this. I'm using the 7i77. Any thoughts on the cause on that board?
I did 8 hrs plus of squaring stock jogging around with the mpg. Haven't had a recurrence but I'm probably due....

Please Log in or Create an account to join the conversation.

More
03 Aug 2018 08:49 #115493 by andypugh
Replied by andypugh on topic MPG count going mad

OT-CNC wrote: Thanks for working on this. I'm using the 7i77. Any thoughts on the cause on that board?

The 7i77 also uses smart-serial MPGs, your problem will be exactly the same cause.


I did 8 hrs plus of squaring stock jogging around with the mpg. Haven't had a recurrence but I'm probably due....

The problem will only appear after a reboot, and will (normally) disappear with another reboot. It will never happen during a run.
The following user(s) said Thank You: OT-CNC

Please Log in or Create an account to join the conversation.

More
03 Aug 2018 23:53 #115564 by andypugh
Replied by andypugh on topic MPG count going mad
I had this again today, updated, and it went away.

Fixed, I think.

Please Log in or Create an account to join the conversation.

More
13 Jul 2019 13:41 #139253 by OT-CNC
Replied by OT-CNC on topic MPG count going mad
I ran into this problem again yesterday. I wonder if me using the machine in manual mode the day before triggers this random behavior?
For clarification, manual mode on this BP mill means me cranking the handles and using linuxcnc as a dro to display position. The encoders are powered and the drives are off. I don't often use it manually. I also have not upgraded or changed anything since it usually just works great.

Andy, when you ran into this, did you use your lathe manually before as a dro?
Before I go upgrade, did it fix the occurrence on your machine?

Please Log in or Create an account to join the conversation.

More
13 Jul 2019 14:22 #139256 by andypugh
Replied by andypugh on topic MPG count going mad
I had forgotten about this. So, yes, it's been a year and I haven't seen the issue.

There is a separate problem where the 7i73 sometimes initialises with massive counts, but it still counts + / - 1 rather than randomly choosing increments between 128 and 1. (it's not truly random, but it feels like it)

Please Log in or Create an account to join the conversation.

Time to create page: 0.082 seconds
Powered by Kunena Forum