having problems to update

More
28 Jan 2020 03:46 #155974 by flexbex
Running linuxcnc wheezy 2.7. Freshly installed from the website.
when using sudo apt-get update I am getting the error
W: Failed to fetch http://http.us.debian.org/debian/dists/wheezy/contrib/binary-i386/Packages  404  Not Found [IP: 64.50.236.52 80]

W: Failed to fetch http://http.us.debian.org/debian/dists/wheezy/non-free/binary-i386/Packages  404  Not Found [IP: 64.50.236.52 80]

W: Failed to fetch http://http.us.debian.org/debian/dists/wheezy/main/binary-i386/Packages  404  Not Found [IP: 64.50.236.52 80]

W: Failed to fetch http://archive.debian.org/debian/dists/wheezy/updates/main/source/Sources  404  Not Found [IP: 130.89.148.13 80]

W: Failed to fetch http://archive.debian.org/debian/dists/wheezy/updates/contrib/source/Sources  404  Not Found [IP: 130.89.148.13 80]

W: Failed to fetch http://archive.debian.org/debian/dists/wheezy/updates/non-free/source/Sources  404  Not Found [IP: 130.89.148.13 80]

W: Failed to fetch http://archive.debian.org/debian/dists/wheezy/updates/main/binary-i386/Packages  404  Not Found [IP: 130.89.148.13 80]

W: Failed to fetch http://archive.debian.org/debian/dists/wheezy/updates/contrib/binary-i386/Packages  404  Not Found [IP: 130.89.148.13 80]

W: Failed to fetch http://archive.debian.org/debian/dists/wheezy/updates/non-free/binary-i386/Packages  404  Not Found [IP: 130.89.148.13 80]

E: Some index files failed to download. They have been ignored, or old ones used instead.

Before I also had an error with
Release file for http://archive.debian.org/debian-security/dists/wheezy/updates/Release is expired

but fixed it with adding a file to /etc/apt/apt.conf.d
file: 10no-valid-until
text: Acquire::Check-Valid-Until "0";

I also get an error when using find best server it tells me that there is no suitable server.
The following user(s) said Thank You: yamaplos

Please Log in or Create an account to join the conversation.

More
28 Jan 2020 05:00 #155975 by BeagleBrainz
Answer is here

forum.linuxcnc.org/38-general-linuxcnc-q...itory-expired#155502

Note which lines have been commented out
The following user(s) said Thank You: flexbex, yamaplos

Please Log in or Create an account to join the conversation.

More
06 Feb 2020 14:46 #156637 by andypugh
Replied by andypugh on topic having problems to update
It seems that the problem might be that the selected mirror does not mirror the archive versions.

I strongly suggest at least trying the Debian 9 / Stretch uspace version of LinuxCNC if doing a fresh install.
www.linuxcnc.org/downloads/

Please Log in or Create an account to join the conversation.

More
13 May 2020 01:29 #167592 by yamaplos
Replied by yamaplos on topic having problems to update
@flexbex
You are now my favorite geek of all time. The 10no-valid-until file did the trick of passing the Release is expired (or so it seems),
I have now been able FINALLY to install Geany

:p In the name of all silly, why does LinuxCNC pack all of Libreoffice but NO decent plain text editor? :p
Anyway, much gratitude to LinuxCNC developers, even so. Having much fun.

I might even be able to fix a few more things that I had learned to live with.

Thank you again. Hope your problem gets solved also.

Please Log in or Create an account to join the conversation.

More
13 May 2020 01:52 #167593 by BeagleBrainz
There is also a remastered Mint 19.2 version that has Linuxcnc installed & geany, as that's my 2nd favourite text editor....I kinda prefer the editor that comes with midnight commander for general use.

Please Log in or Create an account to join the conversation.

Time to create page: 0.206 seconds
Powered by Kunena Forum