Error on start unexpected realtime delay task 0 or task1

More
05 May 2020 10:46 #166759 by gzcwnk
I have tried a lot of settings 2000 up to 15000 and no joy
Attachments:

Please Log in or Create an account to join the conversation.

More
05 May 2020 10:50 #166762 by tommylight
Set it to 50000 and test again.
Did you disable everything regarding power savings in BIOS ?

Please Log in or Create an account to join the conversation.

More
05 May 2020 19:18 #166791 by gzcwnk
Yes, original test was 4600 and that didnt work. So reading posts here itsaid Nvidia cards can do it so I pulled the Quadro and put in a AMD 4850/4860. Next I went through and turned off all power saving and speed step stuff I could find, that dropped the test to 2600 (which is interesting in itself). I will have a go at 50000, but that's un-usable? and for a 3.4ghz i7 with 16gb of ram seems, terrible?

Please Log in or Create an account to join the conversation.

More
05 May 2020 19:24 #166792 by tommylight

gzcwnk wrote: I will have a go at 50000, but that's un-usable? and for a 3.4ghz i7 with 16gb of ram seems, terrible?

It is very usable, it can still do 20000 pulses per second, and later when you have everything working you can try to lower it if you eventually need more velocity.

Please Log in or Create an account to join the conversation.

More
05 May 2020 19:28 #166793 by gzcwnk
same error at 50000 on start up.

Please Log in or Create an account to join the conversation.

More
05 May 2020 19:49 #166794 by gzcwnk
Latency test is 300 ish. I will pull the hd, put another in and try the newer LinuxCNC on stretch but I had a very similar error off the usb key.

Please Log in or Create an account to join the conversation.

More
05 May 2020 20:24 #166797 by gzcwnk
"I remember that from the days of Linuxcnc when it was EMC2 on Ubuntu 8.04, had to add that for older laptops.
Not sure if that would help, and not sure that disabling that will have such an impact on computer speed. It is used for the ability to use more than 15 IRQ ( interrupt requests ) but i have never seen anything use IRQ's over number 15, ever"

My PP card has an IRQ of 16, so maybe its
this?

Please Log in or Create an account to join the conversation.

More
05 May 2020 22:30 #166809 by tommylight
Check if hyperthreading is disabled, that is a must.
Then see if there is anything about disabling C states.
IRQ 16 is ok, it all depends on what it is shared with and if there is anything you can do about changing that?
Also having an SSD helps a lot for preventing latency excursions, but if you got that same error from a live session, see if you can change the above before moving to SSD.

Please Log in or Create an account to join the conversation.

More
05 May 2020 22:45 #166812 by gzcwnk
Yes Hyper is disabled, C states is not ticked so I assume that's OK its something I changed. I will remove the second NIC and see how that goes.

Please Log in or Create an account to join the conversation.

More
05 May 2020 22:50 #166813 by gzcwnk
Now IRQ 18, same issue

Please Log in or Create an account to join the conversation.

Time to create page: 0.090 seconds
Powered by Kunena Forum