Encoder Feedback

More
13 Jan 2021 18:49 #195232 by Hamel2020
Encoder Feedback was created by Hamel2020
Hi ..

1. I Have a 7i76e+7i85s , mesa cards , setup and flashed ok , trying to use my delta servo drive and motor as the attached images ,
2. I did the wiring as position control (step and DR) .
3. I have a difficulty to setup the encoder output , always I get [ joint 0 following error ] also I did not see the encoder output on the hal oscilloscope !

I attached the hal and ini files also the driver and motor
Need advice please …
Thanks
Hamel

Please Log in or Create an account to join the conversation.

More
13 Jan 2021 19:40 #195236 by PCW
Replied by PCW on topic Encoder Feedback
Encoder 0 would be on the 7I85S

Please Log in or Create an account to join the conversation.

More
13 Jan 2021 19:44 #195237 by Hamel2020
Replied by Hamel2020 on topic Encoder Feedback
Hi Peter ,,
Thank you for quick reply ,
then what is the no. of the encoder in 7i76e card ?

Please Log in or Create an account to join the conversation.

More
13 Jan 2021 19:54 #195240 by PCW
Replied by PCW on topic Encoder Feedback
4

Please Log in or Create an account to join the conversation.

More
14 Jan 2021 16:36 #195333 by Hamel2020
Replied by Hamel2020 on topic Encoder Feedback
Encoder wiring change as per the img .
I have 3 phase encoder output (shown in the img with connection) ,...
(when I rotate the motor shaft by hand ,the encoder show moving signal )
but still I got joint following error , and both signal from the encoder are negative , try to swap the wires .. I got bot +ve ...
I do not know who to manage ...
Attachments:

Please Log in or Create an account to join the conversation.

More
14 Jan 2021 16:50 #195337 by PCW
Replied by PCW on topic Encoder Feedback
Is the encoder position correct (scaled right and in the proper direction)?

Please Log in or Create an account to join the conversation.

More
14 Jan 2021 17:07 #195339 by Hamel2020
Replied by Hamel2020 on topic Encoder Feedback
No ... when the driver enable it shows negative in both motion direction (X+ , and X-) ...for very small movement then show joint following error .

But when I disable the driver ,and rotate the shaft with by hand shows
+ when moving CCW , and - when moving CW

Please Log in or Create an account to join the conversation.

More
14 Jan 2021 17:17 #195344 by PCW
Replied by PCW on topic Encoder Feedback
So you are saying the encoder position moves in a more negative direction
when the servo moves in either direction?

Please Log in or Create an account to join the conversation.

More
14 Jan 2021 17:22 #195346 by Hamel2020
Replied by Hamel2020 on topic Encoder Feedback
exactly

Please Log in or Create an account to join the conversation.

More
14 Jan 2021 17:34 #195351 by PCW
Replied by PCW on topic Encoder Feedback
OK That sounds like an electrical noise issue
Do the drive and 7I76E/7I85 have a common ground?

Please Log in or Create an account to join the conversation.

Time to create page: 0.079 seconds
Powered by Kunena Forum