Connection problems after replacement of motherboard

More
07 May 2021 15:56 #208227 by BastianMC
Hi,

My LinuxCNC PC crashed with a dead motherboard. I swapped the motherboard and CPU for new hardware but kept the SDD drive with my linux installation on it. The motherboard has the ethernet card build in.

After getting the PC up and running again im struggeling to open my MESA launcher.
I can ping the MESA7i96 card on IP 10.10.10.1 just fine with low latenchy i can also use the Mesaflash commands to get info off the board.

However i CANT open the MEsa console and opperate the machine as i get an error. I have attached the error report and my .hal file. Does some one have a tip that coudl help me?
Attachments:

Please Log in or Create an account to join the conversation.

More
07 May 2021 17:05 #208234 by tommylight
loadrt hm2_eth board_ip="192.168.1.121" config=" num_encoders=1 num_pwmgens=1 num_stepgens=4 sserial_port_0=00xxxx"
That is in your hal file, change the IP address.

Please Log in or Create an account to join the conversation.

More
07 May 2021 17:10 #208235 by BastianMC
Thank you Tommy, that was the IP i used to set it up on the first PC. I have tried changing that to 10.10.10.1 as per the new configuration but it dosent change anything for me. Still get the same error.

Please Log in or Create an account to join the conversation.

More
07 May 2021 17:23 #208237 by BastianMC

tommylight wrote: loadrt hm2_eth board_ip="192.168.1.121" config=" num_encoders=1 num_pwmgens=1 num_stepgens=4 sserial_port_0=00xxxx"
That is in your hal file, change the IP address.


I have now tried to set the jumper W5 to down and W6 to up and reset the .hal file IP to 10.10.10.10 and changed the ethernet IPv4 accordingly.
I can connect to the board via ping now problem but i cant open the LinuxCNC UI to control the machine, the error im getting is the same as before: Could not retrieve MAC adresse.

Any other suggestions?

Please Log in or Create an account to join the conversation.

More
07 May 2021 17:30 #208238 by BastianMC

BastianMC wrote:

tommylight wrote: loadrt hm2_eth board_ip="192.168.1.121" config=" num_encoders=1 num_pwmgens=1 num_stepgens=4 sserial_port_0=00xxxx"
That is in your hal file, change the IP address.


I have now tried to set the jumper W5 to down and W6 to up and reset the .hal file IP to 10.10.10.10 and changed the ethernet IPv4 accordingly.
I can connect to the board via ping now problem but i cant open the LinuxCNC UI to control the machine, the error im getting is the same as before: Could not retrieve MAC adresse.

Any other suggestions?


SOLVES! I messed up the adress.... i made a typo should have put in 10.10.10.11

Please Log in or Create an account to join the conversation.

More
07 May 2021 20:06 #208254 by tommylight

BastianMC wrote: I can connect to the board via ping now problem but i cant open the LinuxCNC UI to control the machine, the error im getting is the same as before: Could not retrieve MAC adresse.

That is just a warning, not an error and things will work despite the warning.
Glad you got it going.

Please Log in or Create an account to join the conversation.

Time to create page: 0.085 seconds
Powered by Kunena Forum