Operaor Error With raspberrypi

More
17 Apr 2024 15:22 #298456 by Abdulkareem
i am running linuxcnc on raspberrypi 4, and sometimes this error message is shown
 
Attachments:

Please Log in or Create an account to join the conversation.

More
17 Apr 2024 15:58 #298457 by PCW
Replied by PCW on topic Operaor Error With raspberrypi
That indicates a real time issue on the RPI

Have you run a latency test?

Please Log in or Create an account to join the conversation.

More
18 Apr 2024 11:00 #298545 by Abdulkareem
Yes I did 
Attachments:

Please Log in or Create an account to join the conversation.

More
18 Apr 2024 11:20 #298548 by cornholio
It's going to help if you can describe your system, are you using ethernet, SPI or gpios (software steeping). Mesa, remora or other hardware.

Your HAl & INI files will help as well.
The following user(s) said Thank You: meister

Please Log in or Create an account to join the conversation.

More
18 Apr 2024 12:27 #298551 by Abdulkareem
i am using ethernet and mesa 7i96s 

File Attachment:

File Name: Dental_CNC.hal
File Size:15 KB
 

File Attachment:

File Name: Dental_CNC.ini
File Size:6 KB
Attachments:

Please Log in or Create an account to join the conversation.

More
18 Apr 2024 14:23 #298560 by PCW
Replied by PCW on topic Operaor Error With raspberrypi
Typically with a RPI4 you need to

set the force_turbo option true (in config.txt)
set isolcpus to 2,3 (in cmdline.txt)

You may also need to lower the servo thread
period to 2ms  (2000000)
The following user(s) said Thank You: Abdulkareem

Please Log in or Create an account to join the conversation.

More
21 Apr 2024 15:04 #298781 by Abdulkareem
How to lower the servo thread period?

Please Log in or Create an account to join the conversation.

More
21 Apr 2024 15:09 #298784 by PCW
Replied by PCW on topic Operaor Error With raspberrypi
Change
SERVO_PERIOD = 1000000

to
SERVO_PERIOD = 2000000
The following user(s) said Thank You: cornholio, Abdulkareem

Please Log in or Create an account to join the conversation.

More
21 Apr 2024 15:10 #298785 by cornholio
Change in your ini file
SERVO_PERIOD = 1000000
to
SERVO_PERIOD = 2000000
The following user(s) said Thank You: Abdulkareem

Please Log in or Create an account to join the conversation.

More
06 May 2024 10:37 #299929 by Abdulkareem
I was wondering if I used a mini industrial PC, will I get higher speeds

Please Log in or Create an account to join the conversation.

Time to create page: 0.217 seconds
Powered by Kunena Forum