Arcs / Circles not concentric

More
18 Apr 2024 21:49 #298579 by jstewart
Greetings,

I have encountered a (for me) rather strange issue that I, even after a day of experimenting, can't seem to fully understand.
I have a stepper-motor driven CNC that used to work marvelous for years until recently, when I decided to update the machine to LinuxCNC 2.9.1. That update gave me nothing but pain, i.e. latency increased by a factor of 10, my touch screen was no longer working, operation of gmoccapy was incredibly sluggish etc.

I was quite busy otherwise, so I simply ignored the problem for a while, stuck to operating the machine with an external keyboard and continued. Yesterday, I eventually had to mill some parts as part of an official project, so I decided I'd finally tackle the problem and tried the naive approach first, that is, updating to 2.9.2. That didn't do much at all, plus I discovered something completely different that has been bugging me every since: circles (or arcs, depending how you want to look at it) are no longer being milled concentric.

The arc/circle itself is fine, i.e. perfectly round, but given an arc and a circle with identical reference (center) points, they are slightly offset to each other. Naturally, I checked the DXF, both entities have the same center point - LinuxCNC also draws them correctly on top of each other when processing the GCODE. I also uploaded the code generated by my cam software to an online GCODE viewer, again, both entities are sitting on top of each other just fine.

Facing this new problem, I bit the bullet and downgraded back to 2.8.4, which resolved almost all of my problems, i.e. the touch screen works again, UI response time is instant and so on. It also made the actual issue better, out of 4 pairs of arcs/circles, only two pairs are now offset, and the offsets have become smaller in general. In general, we're talking of an absolute error distance of 1mm to 1.5mm though.

I'll attach the generated GCODE just in case someone wants to have a look at it, it's a really basic operation for a 6mm D - shaft encoder cap.
 

File Attachment:

File Name: gcode.txt
File Size:11 KB


Maybe I'm coping here, but I somehow doubt that it's e.g. step loss since the machine worked in an identical configuration with precision for literally years (and is well maintained). The Gecko drivers, motors and power supply are definitely capable of driving the machine. Plus, I'm cutting decorative knobs out of wood here with a 2kW spindle, so nothing demanding. I'm also running Mesa interface cards. I'll run a few more ops and check position accuracy with a dial test indicator again, but so far, everything looked good.

Does anyone have any idea what I could check to narrow my problem down further? Any ideas, approaches, pointers would be appreciated.

Cheers,

James

 
Attachments:

Please Log in or Create an account to join the conversation.

More
20 Apr 2024 10:35 #298714 by andypugh
I don't have any real insight at the moment into your main problem as I am sat on a train with a Macbook. But I think that you might be misunderstanding what is required to upgrade LinuxCNC. It sounds like you are completely replacing the OS and realtime system every time, rathe than just the LinuxCNC application.

The table here: wiki.linuxcnc.org/cgi-bin/wiki.pl?MinimumSoftwareVersions summarises which LinuxCNC versions are usable on which OS versions.

Which Linux version are you on? "lsb_release -a" and "uname -r" commands will tell you what you need to know.

Please Log in or Create an account to join the conversation.

Time to create page: 0.091 seconds
Powered by Kunena Forum