servo motor are jittering

More
13 May 2024 08:02 #300492 by fiveseven
i recently started a conversion on an old(ish) tos f2vcnc. but now i got the servo working the motors are jittering when standing still.. at the same frequntie and amplitude. almost like its overshooting its position goal. i have tried pid tuning but nothong takes the jitter away anyone nows what the problm might be? i will upload some pictures later. the drives are baumuller bus3. the picture is of when i was still building it up its all conected now.

Please Log in or Create an account to join the conversation.

More
13 May 2024 20:47 #300530 by fiveseven
Replied by fiveseven on topic servo motor are jittering
this is how the ferror looks
Attachments:

Please Log in or Create an account to join the conversation.

More
13 May 2024 21:37 #300534 by tommylight

the picture is of when i was still building it up its all conected now.

What picture? :)
Have a read through this, skip the wiring and testing part:
forum.linuxcnc.org/10-advanced-configura...ning-detailed-how-to

Please Log in or Create an account to join the conversation.

More
13 May 2024 21:37 #300535 by PCW
Replied by PCW on topic servo motor are jittering
Hard to tell from the plot (higher vertical gain would help)
but it sort of looks like +- 1 count dither. If this is the case
(and that jitter is only +-1 micron or so) you could add some
deadband to the PID controller to lessen the dither.

Please Log in or Create an account to join the conversation.

More
13 May 2024 21:42 #300537 by tommylight
Yeah, forgot to ask, if you put your hand on the motor, does it vibrate and how much?

Please Log in or Create an account to join the conversation.

More
14 May 2024 20:06 #300598 by fiveseven
Replied by fiveseven on topic servo motor are jittering
yes the motors are vibrating a bit not enough to see enough to feel it. i will try to add some to the deadband and see if it fixes it.

Please Log in or Create an account to join the conversation.

More
15 May 2024 19:19 #300692 by fiveseven
Replied by fiveseven on topic servo motor are jittering
turns out it was EMI all along. rewired it and its not all gone but its way better and good enough.
The following user(s) said Thank You: tommylight

Please Log in or Create an account to join the conversation.

Time to create page: 0.279 seconds
Powered by Kunena Forum