spindle control

More
16 Aug 2010 08:06 #3772 by M4MazakUser
spindle control was created by M4MazakUser
HELP!

i have now got a running machine, but can't get the spindle index pulse working.

my setup was originally generated by the Pncconf, and looks nothing like any others.

my problem is the encoder settings for my spindle.

setp hm2_5i20.0.encoder.02.counter-mode false
setp hm2_5i20.0.encoder.02.filter true
setp hm2_5i20.0.encoder.02.index-invert 0
setp hm2_5i20.0.encoder.02.index-enable 1
setp hm2_5i20.0.encoder.02.index-mask 0
setp hm2_5i20.0.encoder.02.index-mask-invert 0
setp hm2_5i20.0.encoder.02.scale [SPINDLE_9]INPUT_SCALE
net spindle-vel-fb <= hm2_5i20.0.encoder.02.velocity
net spindle-index-enable <=> hm2_5i20.0.encoder.02.index-enable

# ---setup spindle control signals---

net spindle-cw <= motion.spindle-forward
net spindle-ccw <= motion.spindle-reverse

net spindle-vel-cmd-rps <= motion.spindle-speed-out-rps
net spindle-vel-cmd <= motion.spindle-speed-out
net spindle-enable <= motion.spindle-on

net spindle-vel-cmd => near.0.in1
net spindle-vel-fb => near.0.in2

# net spindle-brake <= motion.spindle-brake
net spindle-revs => motion.spindle-revs
net spindle-at-speed motion.spindle-at-speed <= near.0.out
net spindle-vel-fb => motion.spindle-speed-in
net spindle-index-enable <=> motion.spindle-index-enable
setp near.0.scale 1.07

i have checked the pinouts on my card, 14 - 15 - 17 a,b, z
and they all work. but! theZ channel is not making the spindle-index-enable work.

i.e. the z channel just counts and dosen't reset every revolution.
this means i have a big ZERO in spindle-revs

any help appreciated as i've tried and read all i can...

i want feed per rev!

Please Log in or Create an account to join the conversation.

More
16 Aug 2010 13:07 #3774 by BigJohnT
Replied by BigJohnT on topic Re:spindle control
Is your motion spindle at speed true (not sure of the exact syntax)? Spindle sync waits for spindle at speed...

John

Please Log in or Create an account to join the conversation.

More
16 Aug 2010 20:07 - 16 Aug 2010 20:12 #3775 by M4MazakUser
Replied by M4MazakUser on topic Re:spindle control
yes that works fine

net spindle-vel-fb => motion.spindle-speed-in


this float displays the correct speed
Last edit: 16 Aug 2010 20:12 by M4MazakUser.

Please Log in or Create an account to join the conversation.

More
16 Aug 2010 21:38 #3777 by BigJohnT
Replied by BigJohnT on topic Re:spindle control
Not the spindle speed but the motion.spindle-at-speed must be "true".

John

Please Log in or Create an account to join the conversation.

More
17 Aug 2010 04:17 #3780 by cmorley
Replied by cmorley on topic Re:spindle control
What version of EMC are you using ? Could you post your pncconf files?
spindle configuration has not been tested well in pncconf but we'll fix em as soon as we find them.

Please Log in or Create an account to join the conversation.

More
17 Aug 2010 07:52 #3782 by M4MazakUser
Replied by M4MazakUser on topic Re:spindle control
The spindle at speed works properly, (the bit is on when the speed is in range -I am using near)
I'll post the config files tomorrow, I installed from the live cd, 4weeks ago, I'll check versions.

Please Log in or Create an account to join the conversation.

More
17 Aug 2010 11:42 #3787 by BigJohnT
Replied by BigJohnT on topic Re:spindle control
I think the Z needs some kind of reset let me check my config on my lathe to see if I can find it.

John

Please Log in or Create an account to join the conversation.

More
17 Aug 2010 11:58 #3788 by M4MazakUser
Replied by M4MazakUser on topic Re:spindle control
Yes in my thinking, the spindle index should reset the count every revolution therefore making the spindle revs a meaningful number. This would also make the spindle position meaningful.

Please Log in or Create an account to join the conversation.

More
17 Aug 2010 12:05 - 17 Aug 2010 12:06 #3789 by BigJohnT
Replied by BigJohnT on topic Re:spindle control
I see the problem finally!

net spindle-index-enable <=> hm2_5i20.0.encoder.02.index-enable

should be

net spindle-index motion.spindle-index-enable <= hm2_5i20.0.encoder.02.index-enable

John
Last edit: 17 Aug 2010 12:06 by BigJohnT.

Please Log in or Create an account to join the conversation.

More
17 Aug 2010 12:24 #3790 by M4MazakUser
Replied by M4MazakUser on topic Re:spindle control
Thanks! I'll give that a try tomorrow, looks to me that should be it.

As long as it tis noted that this is as it was written from pncconf !

Thanks!

Please Log in or Create an account to join the conversation.

Moderators: cmorley
Time to create page: 0.100 seconds
Powered by Kunena Forum